Patch #29999

Updated by Go MAEDA 6 months ago

Redmine uses rdoc gem 4.3.0 that was released 2 years ago. According to the commit log of r15945, this is because the newer versions of rdoc requires RubyGems 2.2 which is too high for Redmine at that time.

But now, the current trunk requires Ruby >=2.2, so we can assume that the version of RubyGems is at least 2.4.5. We can update RubyGems to the latest version.

<pre><code class="diff"> class=&quot;ruby&quot;&gt;
Index: Gemfile
===================================================================
--- Gemfile (revision 17629)
+++ Gemfile (working copy)
@@ -79,7 +79,7 @@
end

group :development do
- gem "rdoc", "~> 4.3"
+ gem "rdoc"
gem "yard"
end
</code></pre>

Back