4.1-stable build 171

Revision r21224 (build 171 started on 2021-09-29T21:59:08Z)


originally caused by:
 Started by an SCM change
Building in workspace /var/lib/jenkins/workspace/4.1-stable/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.4
Updating http://svn.redmine.org/redmine/branches/4.1-stable at revision '2021-09-29T14:59:08.145 -0700'
U         public/stylesheets/application.css
 U        .
At revision 21224

[ruby-2.4] $ /bin/sh -xe /tmp/jenkins739775632050457266.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.4/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games rake -f lib/tasks/ci.rake config/database.yml BRANCH=4.1-stable
[ruby-2.4] $ /bin/sh -xe /tmp/jenkins2078731089915551543.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.4/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games bundle update
The latest bundler is 2.2.28, but you are currently running 1.15.3.
To update, run `gem install bundler`
The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x64-mingw32, x86-mswin32. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x64-mingw32 x86-mswin32`.
The dependency ffi (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x64-mingw32, x86-mswin32. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x64-mingw32 x86-mswin32`.
Fetching gem metadata from https://rubygems.org/...........
Fetching version metadata from https://rubygems.org/...
Fetching dependency metadata from https://rubygems.org/..
Resolving dependencies...
Using rake 13.0.6
Using concurrent-ruby 1.1.9
Using minitest 5.14.4
Using thread_safe 0.3.6
Using builder 3.2.4
Using erubi 1.10.0
Using mini_portile2 2.4.0
Using crass 1.0.6
Using rack 2.2.3
Using nio4r 2.5.8
Using websocket-extensions 0.1.5
Using mini_mime 1.0.3
Using method_source 1.0.0
Using thor 1.1.0
Using arel 9.0.0
Fetching marcel 1.0.2 (was 1.0.1)
Installing marcel 1.0.2 (was 1.0.1)
Using public_suffix 4.0.6
Using ast 2.4.2
Using bundler 1.15.3
Using regexp_parser 1.8.2
Using childprocess 3.0.0
Using csv 3.1.5
Fetching docile 1.4.0 (was 1.3.5)
Installing docile 1.4.0 (was 1.3.5)
Using htmlentities 4.3.4
Using jaro_winkler 1.5.4
Using json 2.5.1
Using mini_magick 4.9.5
Using mocha 1.13.0
Using net-ldap 0.16.3
Fetching parallel 1.21.0 (was 1.20.1)
Installing parallel 1.21.0 (was 1.20.1)
Using puma 3.12.6
Using ruby-openid 2.9.2
Using rainbow 3.0.0
Using rbpdf-font 1.19.1
Using redcarpet 3.5.1
Using rouge 3.12.0
Using ruby-progressbar 1.11.0
Using unicode-display_width 1.6.1
Using rubyzip 2.3.2
Using simplecov-html 0.10.2
Using sqlite3 1.4.2
Using yard 0.9.26
Using i18n 1.6.0
Using tzinfo 1.2.9
Using nokogiri 1.10.10
Using rack-test 1.1.0
Using sprockets 3.7.2
Using request_store 1.4.1
Using websocket-driver 0.7.5
Using mail 2.7.1
Using addressable 2.8.0
Using parser 3.0.2.0
Gem::InstallError: docile requires Ruby version >= 2.5.0.
An error occurred while installing docile (1.4.0), and Bundler cannot continue.
Make sure that `gem install docile -v '1.4.0'` succeeds before bundling.

In Gemfile:
  simplecov was resolved to 0.17.1, which depends on
    docile
Build step 'Execute shell' marked build as failure
Finished: FAILURE