4.2-stable build 108

Revision r21779 (build 108 started on 2022-08-25T14:04:09Z)


originally caused by:
 Started by an SCM change
Building in workspace /var/lib/jenkins/workspace/4.2-stable/DATABASE_ADAPTER/postgresql/RUBY_VER/ruby-2.4
Updating http://svn.redmine.org/redmine/branches/4.2-stable at revision '2022-08-25T07:04:09.460 -0700'
U         app/models/setting.rb
 U        .
At revision 21779

[ruby-2.4] $ /bin/sh -xe /tmp/jenkins1624877848313865017.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.4/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games rake -f lib/tasks/ci.rake config/database.yml BRANCH=4.2-stable
[ruby-2.4] $ /bin/sh -xe /tmp/jenkins4447686357919021454.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.4/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games bundle update
The latest bundler is 2.3.21, but you are currently running 1.15.3.
To update, run `gem install bundler`
The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x64-mingw32, x86-mswin32. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x64-mingw32 x86-mswin32`.
The dependency ffi (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x64-mingw32, x86-mswin32. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x64-mingw32 x86-mswin32`.
/var/lib/jenkins/ruby/ruby-2.4.1/lib/ruby/gems/2.4.0/gems/psych-3.3.2/lib/psych.rb:236: warning: already initialized constant Psych::LIBYAML_VERSION
/var/lib/jenkins/ruby/ruby-2.4.1/lib/ruby/2.4.0/psych.rb:228: warning: previous definition of LIBYAML_VERSION was here
Fetching gem metadata from https://rubygems.org/..........
Fetching version metadata from https://rubygems.org/..
Fetching dependency metadata from https://rubygems.org/.
Resolving dependencies....
Using rake 13.0.6
Using concurrent-ruby 1.1.10
Using minitest 5.15.0
Using thread_safe 0.3.6
Using builder 3.2.4
Fetching erubi 1.11.0 (was 1.10.0)
Using mini_portile2 2.4.0
Using crass 1.0.6
Using rack 2.2.4
Using nio4r 2.5.8
Using websocket-extensions 0.1.5
Using mini_mime 1.0.3
Using method_source 1.0.0
Using thor 1.2.1
Using arel 9.0.0
Using marcel 1.0.2
Using public_suffix 4.0.7
Using ast 2.4.2
Using bundler 1.15.3
Using regexp_parser 1.8.2
Using childprocess 3.0.0
Using chunky_png 1.4.0
Using csv 3.1.5
Using docile 1.3.5
Using htmlentities 4.3.4
Using mini_magick 4.11.0
Using mocha 1.14.0
Using net-ldap 0.17.1
Using parallel 1.20.1
Using pg 1.2.3
Using psych 3.3.2
Using ruby-openid 2.9.2
Using rainbow 3.1.1
Using rbpdf-font 1.19.1
Using redcarpet 3.5.1
Using rexml 3.2.5
Using rotp 6.2.0
Using rouge 3.26.1
Using rqrcode_core 1.2.0
Using ruby-progressbar 1.11.0
Using unicode-display_width 2.2.0
Using rubyzip 2.3.2
Using simplecov-html 0.12.3
Using webrick 1.7.0
Using i18n 1.8.11
Using tzinfo 1.2.10
ArgumentError: wrong number of arguments (given 1, expected 0)
An error occurred while installing erubi (1.11.0), and Bundler cannot continue.
Make sure that `gem install erubi -v '1.11.0'` succeeds before bundling.

In Gemfile:
  rails was resolved to 5.2.8.1, which depends on
    actioncable was resolved to 5.2.8.1, which depends on
      actionpack was resolved to 5.2.8.1, which depends on
        actionview was resolved to 5.2.8.1, which depends on
          erubi
Build step 'Execute shell' marked build as failure
Finished: FAILURE