4.2-stable build 106

Revision r21761 (build 106 started on 2022-08-06T04:46:06Z)


originally caused by:
 Started by an SCM change
Building in workspace /var/lib/jenkins/workspace/4.2-stable/DATABASE_ADAPTER/postgresql/RUBY_VER/ruby-2.6
Updating http://svn.redmine.org/redmine/branches/4.2-stable at revision '2022-08-05T21:46:06.377 -0700'
U         public/javascripts/context_menu.js
 U        .
At revision 21761

[ruby-2.6] $ /bin/sh -xe /tmp/jenkins4448884339672784543.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.6/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games rake -f lib/tasks/ci.rake config/database.yml BRANCH=4.2-stable
[ruby-2.6] $ /bin/sh -xe /tmp/jenkins2035591417654147728.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.6/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games bundle update
Fetching gem metadata from https://rubygems.org/..........
Resolving dependencies.....
Using rake 13.0.6
Using concurrent-ruby 1.1.10
Using minitest 5.16.2
Using thread_safe 0.3.6
Using builder 3.2.4
Using erubi 1.11.0 (was 1.10.0)
Using mini_portile2 2.8.0
Using racc 1.6.0
Using crass 1.0.6
Using rack 2.2.4
Using nio4r 2.5.8
Using websocket-extensions 0.1.5
Using mini_mime 1.0.3
Using method_source 1.0.0
Using thor 1.2.1
Using arel 9.0.0
Using marcel 1.0.2
Using public_suffix 4.0.7
Using ast 2.4.2
Using bundler 2.3.7
Using childprocess 4.1.0
Using chunky_png 1.4.0
Using csv 3.1.9
Using docile 1.4.0
Using htmlentities 4.3.4
Using mini_magick 4.11.0
Using mocha 1.14.0
Using net-ldap 0.17.1
Using parallel 1.22.1
Using pg 1.2.3
Using ruby-openid 2.9.2
Using rbpdf-font 1.19.1
Using redcarpet 3.5.1
Using rexml 3.2.5
Using rotp 6.2.0
Using rouge 3.26.1
Using rqrcode_core 1.2.0
Using ruby-progressbar 1.11.0
Using unicode-display_width 2.2.0
Using rubyzip 2.3.2
Using simplecov-html 0.12.3
Using webrick 1.7.0
Using rainbow 3.1.1
Using regexp_parser 1.8.2
Using i18n 1.8.11
Using tzinfo 1.2.10
Using nokogiri 1.13.8 (x86-linux) (was 1.13.7)
Using rack-test 2.0.2
Using websocket-driver 0.7.5
Using mail 2.7.1
Using addressable 2.8.0
Using puma 5.6.4
Using parser 3.1.2.0
Using sprockets 4.1.1
Using rbpdf 1.20.1
Using request_store 1.5.1
Using rqrcode 2.1.2 (was 2.1.1)
Using selenium-webdriver 4.1.0
Using simplecov 0.18.5
Using yard 0.9.28
Using activesupport 5.2.8.1
Using loofah 2.18.0
Using xpath 3.2.0
Using rack-openid 1.4.2
Using rails-dom-testing 2.0.3
Using rails-html-sanitizer 1.4.3
Using activemodel 5.2.8.1
Using rubocop-ast 1.19.1
Using webdrivers 4.7.0
Using globalid 1.0.0
Using actionview 5.2.8.1
Using activerecord 5.2.8.1
Using capybara 3.31.0
Using css_parser 1.11.0
Using rubocop 1.12.1
Using actionpack 5.2.8.1
Using activejob 5.2.8.1
Using roadie 4.0.0
Using rubocop-performance 1.10.2
Using rubocop-rails 2.9.1
Using actioncable 5.2.8.1
Using actionmailer 5.2.8.1
Using railties 5.2.8.1
Using activestorage 5.2.8.1
Using sprockets-rails 3.4.2
Using actionpack-xml_parser 2.0.1
Using roadie-rails 2.2.0
Using rails 5.2.8.1
Bundle updated!
[ruby-2.6] $ /bin/sh -xe /tmp/jenkins6612880679971383023.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.6/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games bundle exec rake ci:about ci:setup RAILS_ENV=test
warning: parser/current is loading parser/ruby26, which recognizes2.6.10-compliant syntax, but you are running 2.6.9.
Please see https://github.com/whitequark/parser#compatibility-with-ruby-mri.
Ruby version: 2.6.9-p207 (2021-11-24) [i686-linux]
svn: E155036: Please see the 'svn upgrade' command
svn: E155036: The working copy at '/var/lib/jenkins/workspace/4.2-stable/DATABASE_ADAPTER/postgresql/RUBY_VER/ruby-2.6'
is too old (format 8) to work with client version '1.9.3 (r1718519)' (expects format 31). You need to upgrade the working copy first.

Database 'ci_42stable_ruby26_dev' already exists
Database 'ci_42stable_ruby26_test' already exists
[ruby-2.6] $ /bin/sh -xe /tmp/jenkins6074803283235013936.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.6/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games bundle exec rake test
warning: parser/current is loading parser/ruby26, which recognizes2.6.10-compliant syntax, but you are running 2.6.9.
Please see https://github.com/whitequark/parser#compatibility-with-ruby-mri.
svn: E155036: Please see the 'svn upgrade' command
svn: E155036: The working copy at '/var/lib/jenkins/workspace/4.2-stable/DATABASE_ADAPTER/postgresql/RUBY_VER/ruby-2.6'
is too old (format 8) to work with client version '1.9.3 (r1718519)' (expects format 31). You need to upgrade the working copy first.

(Test LDAP server not configured)
Bazaar non ASCII output test cannot run on this environment.
Encoding.locale_charmap: UTF-8
Skipping LDAP tests.
Run options: --seed 1997

# Running:

.............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................S........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

Finished in 650.355464s, 7.9803 runs/s, 36.8998 assertions/s.
5190 runs, 23998 assertions, 0 failures, 0 errors, 1 skips

You have skipped tests. Run with --verbose for details.
Finished: SUCCESS