trunk build 2020

Revision r21837 (build 2020 started on 2022-09-25T02:36:05Z)


originally caused by:
 Started by an SCM change
Building in workspace /var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/postgresql/RUBY_VER/ruby-3.1
Updating http://svn.redmine.org/redmine/trunk at revision '2022-09-24T19:36:05.436 -0700'
U         config/locales/fa.yml
At revision 21837

[ruby-3.1] $ /bin/sh -xe /tmp/jenkins7974187180899086896.sh
+ PATH=/var/lib/jenkins/ruby/ruby-3.1/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games rake -f lib/tasks/ci.rake config/database.yml BRANCH=trunk
[ruby-3.1] $ /bin/sh -xe /tmp/jenkins7180345944501271048.sh
+ PATH=/var/lib/jenkins/ruby/ruby-3.1/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games bundle update
Fetching gem metadata from https://rubygems.org/.........
Resolving dependencies...
Using rake 13.0.6
Using concurrent-ruby 1.1.10
Using minitest 5.16.3
Using erubi 1.11.0
Using racc 1.6.0
Using crass 1.0.6
Using zeitwerk 2.6.0
Using builder 3.2.4
Using rack 2.2.4
Using nio4r 2.5.8
Using marcel 1.0.2
Using websocket-extensions 0.1.5
Using mini_mime 1.1.2
Using thor 1.2.1
Using method_source 1.0.0
Using ast 2.4.2
Using bundler 2.3.14
Using matrix 0.4.2
Using public_suffix 5.0.0
Using regexp_parser 2.5.0
Using childprocess 3.0.0
Using chunky_png 1.4.0
Using commonmarker 0.23.4
Using csv 3.2.5
Using digest 3.1.0
Using docile 1.4.0
Using ffi 1.15.5
Using htmlentities 4.3.4
Using json 2.6.2
Using rb-fsevent 0.11.2
Using mini_magick 4.11.0
Using mocha 1.15.0
Using timeout 0.3.0
Using strscan 3.0.4
Using net-ldap 0.17.1
Using parallel 1.22.1
Using pg 1.4.3
Using rainbow 3.1.1
Using rbpdf-font 1.19.1
Using redcarpet 3.5.1
Using rexml 3.2.5
Using rotp 6.2.0
Using rouge 3.30.0
Using rqrcode_core 1.2.0
Using ruby-progressbar 1.11.0
Using unicode-display_width 2.3.0
Using rubyzip 2.3.2
Using simplecov-html 0.12.3
Using simplecov_json_formatter 0.1.4
Using webrick 1.7.0
Using i18n 1.12.0
Using tzinfo 2.0.5
Using nokogiri 1.13.8 (x86-linux)
Using rack-test 2.0.2
Using sprockets 4.1.1
Using request_store 1.5.1
Using puma 5.6.5
Using mail 2.7.1
Using parser 3.1.2.1
Using activesupport 6.1.7
Using loofah 2.19.0
Using xpath 3.2.0
Using net-protocol 0.1.3
Using rb-inotify 0.10.1
Using rbpdf 1.20.1
Using rubocop-ast 1.21.0
Using sanitize 6.0.0
Using rqrcode 2.1.2
Using selenium-webdriver 3.142.7
Using simplecov 0.21.2
Using yard 0.9.28
Using rails-dom-testing 2.0.3
Using globalid 1.0.0
Using activemodel 6.1.7
Using html-pipeline 2.13.2
Using net-imap 0.2.3
Using rails-html-sanitizer 1.4.3
Using net-pop 0.1.1
Using net-smtp 0.3.1
Using addressable 2.8.1
Using listen 3.7.1
Using rubocop 1.36.0
Using webdrivers 4.6.1
Using activejob 6.1.7
Using websocket-driver 0.7.5
Using activerecord 6.1.7
Using deckar01-task_list 2.3.2
Using actionview 6.1.7
Using css_parser 1.12.0
Using rubocop-performance 1.15.0
Using capybara 3.36.0
Using actionpack 6.1.7
Using rubocop-rails 2.15.2
Using actioncable 6.1.7
Using activestorage 6.1.7
Using railties 6.1.7
Using actionmailer 6.1.7
Using sprockets-rails 3.4.2
Using actiontext 6.1.7
Using actionmailbox 6.1.7
Using roadie 5.0.1
Using actionpack-xml_parser 2.0.1
Using rails 6.1.7
Using roadie-rails 3.0.0
Bundle updated!
[ruby-3.1] $ /bin/sh -xe /tmp/jenkins8102950899833919909.sh
+ PATH=/var/lib/jenkins/ruby/ruby-3.1/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games SCMS=subversion,git,mercurial,filesystem,bazaar,cvs bundle exec rake ci:about ci:setup db:environment:set RAILS_ENV=test
Database 'ci_trunk_ruby31_dev' already exists
Database 'ci_trunk_ruby31_test' already exists
Ruby version: 3.1.2-p20 (2022-04-12) [i686-linux]
[ruby-3.1] $ /bin/sh -xe /tmp/jenkins5110581442168361447.sh
+ PATH=/var/lib/jenkins/ruby/ruby-3.1/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games bundle exec rake test
(Test LDAP server not configured)
Bazaar non ASCII output test cannot run on this environment.
Encoding.locale_charmap: UTF-8
Git UTF-8 test repository NOT FOUND. Skipping unit tests !!!
Skipping LDAP tests.
Run options: --seed 39114

# Running:

...........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................svn: E155036: Please see the 'svn upgrade' command
svn: E155036: The working copy at '/var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/postgresql/RUBY_VER/ruby-3.1'
is too old (format 8) to work with client version '1.9.3 (r1718519)' (expects format 31). You need to upgrade the working copy first.

.......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................S..............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................F

Failure:
RepositoriesControllerTest#test_show_without_main_repository_should_display_first_repository [/var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/postgresql/RUBY_VER/ruby-3.1/test/functional/repositories_controller_test.rb:208]:
Expected at least 1 element matching "a.repository.selected[href="/projects/ecookbook/repository/test"]", found 0..
Expected 0 to be >= 1.

rails test test/functional/repositories_controller_test.rb:191

..........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

Finished in 724.673160s, 7.5234 runs/s, 34.3451 assertions/s.
5452 runs, 24889 assertions, 1 failures, 0 errors, 1 skips

You have skipped tests. Run with --verbose for details.
Build step 'Execute shell' marked build as failure
Finished: FAILURE