trunk build 51

Revision r17695 (build 51 started on 2018-12-07T09:47:13Z)


originally caused by:
 Started by an SCM change
Building in workspace /var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.5
Updating http://svn.redmine.org/redmine/trunk at revision '2018-12-07T01:47:13.313 -0800'
U         Gemfile
At revision 17695

[ruby-2.5] $ /bin/sh -xe /tmp/jenkins7135501426024708702.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.5/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games rake -f lib/tasks/ci.rake config/database.yml BRANCH=trunk
[ruby-2.5] $ /bin/sh -xe /tmp/jenkins5373695815524840716.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.5/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games bundle update
The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x64-mingw32, x86-mswin32. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x64-mingw32 x86-mswin32`.
Fetching gem metadata from https://rubygems.org/..........
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 12.3.2 (was 12.3.1)
Using concurrent-ruby 1.1.3
Using i18n 0.7.0
Using minitest 5.11.3
Using thread_safe 0.3.6
Using tzinfo 1.2.5
Using activesupport 5.2.2 (was 5.2.1.1)
Using builder 3.2.3
Using erubi 1.7.1
Using mini_portile2 2.3.0
Using nokogiri 1.8.5
Using rails-dom-testing 2.0.3
Using crass 1.0.4
Using loofah 2.2.3
Using rails-html-sanitizer 1.0.4
Using actionview 5.2.2 (was 5.2.1.1)
Using rack 2.0.6
Using rack-test 1.1.0
Using actionpack 5.2.2 (was 5.2.1.1)
Using nio4r 2.3.1
Using websocket-extensions 0.1.3
Using websocket-driver 0.7.0
Using actioncable 5.2.2 (was 5.2.1.1)
Using globalid 0.4.1
Using activejob 5.2.2 (was 5.2.1.1)
Using mini_mime 1.0.1
Using mail 2.7.1
Using actionmailer 5.2.2 (was 5.2.1.1)
Using method_source 0.9.2
Using thor 0.20.3
Using railties 5.2.2 (was 5.2.1.1)
Using actionpack-xml_parser 2.0.1
Using activemodel 5.2.2 (was 5.2.1.1)
Using arel 9.0.0
Using activerecord 5.2.2 (was 5.2.1.1)
Using mimemagic 0.3.2
Using marcel 0.3.3
Using activestorage 5.2.2 (was 5.2.1.1)
Using public_suffix 3.0.3
Using addressable 2.5.2
Using bundler 1.17.1
Using xpath 3.2.0
Using capybara 2.18.0
Using ffi 1.9.25
Using childprocess 0.9.0
Using css_parser 1.6.0
Using csv 1.0.2
Using docile 1.1.5
Using htmlentities 4.3.4
Using json 2.1.0
Using metaclass 0.0.4
Using mocha 1.7.0
Using net-ldap 0.16.1
Using puma 3.12.0
Using ruby-openid 2.3.0
Using rack-openid 1.4.2
Using sprockets 3.7.2
Using sprockets-rails 3.2.1
Using rails 5.2.2 (was 5.2.1.1)
Using rbpdf-font 1.19.1
Using rbpdf 1.19.6
Using rdoc 6.0.4
Using redcarpet 3.4.0
Using request_store 1.0.5
Using rmagick 2.16.0
Using roadie 3.4.0
Using roadie-rails 1.3.0
Using rouge 3.3.0
Using rubyzip 1.2.2
Using selenium-webdriver 3.141.0
Using simplecov-html 0.10.2
Using simplecov 0.14.1
Using sqlite3 1.3.13
Using yard 0.9.16
Bundle updated!
[ruby-2.5] $ /bin/sh -xe /tmp/jenkins8057329418292305607.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.5/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games SCMS=subversion,git,mercurial,filesystem,bazaar,cvs bundle exec rake ci:about ci:setup db:environment:set RAILS_ENV=test
Ruby version: 2.5.3-p105 (2018-10-18) [i686-linux]
svn: E155036: Please see the 'svn upgrade' command
svn: E155036: The working copy at '/var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.5'
is too old (format 8) to work with client version '1.9.3 (r1718519)' (expects format 31). You need to upgrade the working copy first.

Database 'db/ci_trunk_ruby25_dev.sqlite3' already exists
Database 'db/ci_trunk_ruby25_test.sqlite3' already exists
[ruby-2.5] $ /bin/sh -xe /tmp/jenkins5700004658114942276.sh
+ PATH=/var/lib/jenkins/ruby/ruby-2.5/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games bundle exec rake test
svn: E155036: Please see the 'svn upgrade' command
svn: E155036: The working copy at '/var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.5'
is too old (format 8) to work with client version '1.9.3 (r1718519)' (expects format 31). You need to upgrade the working copy first.

Version: ImageMagick 6.8.9-9 Q16 i686 2017-05-26 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2014 ImageMagick Studio LLC
Features: DPC Modules OpenMP
Delegates: bzlib cairo djvu fftw fontconfig freetype jbig jng jpeg lcms lqr ltdl lzma openexr pangocairo png rsvg tiff wmf x xml zlib

Deprecation warning: Net::LDAP::ConnectionRefused will be deprecated. Use Errno::ECONNREFUSED instead.
Deprecation warning: Net::LDAP::ConnectionRefused will be deprecated. Use Errno::ECONNREFUSED instead.
(Test LDAP server not configured)
Bazaar non ASCII output test cannot run on this environment.
Encoding.locale_charmap: UTF-8
Skipping LDAP tests.
Run options: --seed 32809

# Running:

.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................S..............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................F

Failure:
ProjectNestedSetTest#test_adding_a_root_to_last_position_should_update_nested_set_order [/var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.5/test/unit/project_nested_set_test.rb:125]:
Expected: 1
  Actual: nil

bin/rails test test/unit/project_nested_set_test.rb:123

E

Error:
ProjectNestedSetTest#test_moving_a_child_to_a_different_parent_should_keep_valid_tree:
NoMethodError: undefined method `set_parent!' for nil:NilClass
    test/unit/project_nested_set_test.rb:72:in `block in test_moving_a_child_to_a_different_parent_should_keep_valid_tree'
    test/unit/project_nested_set_test.rb:71:in `test_moving_a_child_to_a_different_parent_should_keep_valid_tree'

bin/rails test test/unit/project_nested_set_test.rb:70

E

Error:
ProjectNestedSetTest#test_renaming_a_child_should_update_nested_set_order:
ActiveRecord::RecordInvalid: Validation failed: Enabled modules is invalid
    test/unit/project_nested_set_test.rb:103:in `test_renaming_a_child_should_update_nested_set_order'

bin/rails test test/unit/project_nested_set_test.rb:101

F

Failure:
ProjectNestedSetTest#test_valid_tree [/var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.5/test/unit/project_nested_set_test.rb:46]:
Expected: 1
  Actual: nil

bin/rails test test/unit/project_nested_set_test.rb:45

E

Error:
ProjectNestedSetTest#test_renaming_a_root_to_last_position_should_update_nested_set_order:
ActiveRecord::RecordInvalid: Validation failed: Enabled modules is invalid
    test/unit/project_nested_set_test.rb:91:in `test_renaming_a_root_to_last_position_should_update_nested_set_order'

bin/rails test test/unit/project_nested_set_test.rb:89

E

Error:
ProjectNestedSetTest#test_destroying_a_child_with_children_should_keep_valid_tree:
NoMethodError: undefined method `destroy' for nil:NilClass
    test/unit/project_nested_set_test.rb:137:in `block in test_destroying_a_child_with_children_should_keep_valid_tree'
    test/unit/project_nested_set_test.rb:136:in `test_destroying_a_child_with_children_should_keep_valid_tree'

bin/rails test test/unit/project_nested_set_test.rb:135

E

Error:
ProjectNestedSetTest#test_renaming_a_root_to_first_position_should_update_nested_set_order:
ActiveRecord::RecordInvalid: Validation failed: Enabled modules is invalid
    test/unit/project_nested_set_test.rb:79:in `test_renaming_a_root_to_first_position_should_update_nested_set_order'

bin/rails test test/unit/project_nested_set_test.rb:77

E

Error:
ProjectNestedSetTest#test_renaming_a_child_with_child_should_update_nested_set_order:
ActiveRecord::RecordInvalid: Validation failed: Enabled modules is invalid
    test/unit/project_nested_set_test.rb:109:in `test_renaming_a_child_with_child_should_update_nested_set_order'

bin/rails test test/unit/project_nested_set_test.rb:107

E

Error:
ProjectNestedSetTest#test_renaming_a_root_to_middle_position_should_update_nested_set_order:
ActiveRecord::RecordInvalid: Validation failed: Enabled modules is invalid
    test/unit/project_nested_set_test.rb:85:in `test_renaming_a_root_to_middle_position_should_update_nested_set_order'

bin/rails test test/unit/project_nested_set_test.rb:83

F

Failure:
ProjectNestedSetTest#test_adding_a_root_to_first_position_should_update_nested_set_order [/var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.5/test/unit/project_nested_set_test.rb:115]:
Expected: 1
  Actual: nil

bin/rails test test/unit/project_nested_set_test.rb:113

E

Error:
ProjectNestedSetTest#test_renaming_a_root_to_same_position_should_update_nested_set_order:
ActiveRecord::RecordInvalid: Validation failed: Enabled modules is invalid
    test/unit/project_nested_set_test.rb:97:in `test_renaming_a_root_to_same_position_should_update_nested_set_order'

bin/rails test test/unit/project_nested_set_test.rb:95

F

Failure:
ProjectNestedSetTest#test_rebuild_tree_should_build_valid_tree_even_with_valid_lft_rgt_values [/var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.5/test/unit/project_nested_set_test.rb:62]:
Expected: 1
  Actual: nil

bin/rails test test/unit/project_nested_set_test.rb:56

F

Failure:
ProjectNestedSetTest#test_adding_a_root_to_middle_position_should_update_nested_set_order [/var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.5/test/unit/project_nested_set_test.rb:120]:
Expected: 1
  Actual: nil

bin/rails test test/unit/project_nested_set_test.rb:118

E

Error:
ProjectNestedSetTest#test_destroying_a_root_with_children_should_keep_valid_tree:
NoMethodError: undefined method `destroy' for nil:NilClass
    test/unit/project_nested_set_test.rb:130:in `block in test_destroying_a_root_with_children_should_keep_valid_tree'
    test/unit/project_nested_set_test.rb:129:in `test_destroying_a_root_with_children_should_keep_valid_tree'

bin/rails test test/unit/project_nested_set_test.rb:128

F

Failure:
ProjectNestedSetTest#test_rebuild_should_build_valid_tree [/var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.5/test/unit/project_nested_set_test.rb:53]:
Expected: 1
  Actual: nil

bin/rails test test/unit/project_nested_set_test.rb:49

..........................................................................................................................................F

Failure:
IssuesCustomFieldsVisibilityTest#test_create_should_send_notifications_according_custom_fields_visibility [/var/lib/jenkins/workspace/trunk/DATABASE_ADAPTER/sqlite3/RUBY_VER/ruby-2.5/test/functional/issues_custom_fields_visibility_test.rb:270]:
Expected response to be a <302: Found>, but was a <200: OK>.
Expected: 302
  Actual: 200

bin/rails test test/functional/issues_custom_fields_visibility_test.rb:263

............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................SS....................................................................................................

Finished in 306.036243s, 15.3184 runs/s, 67.6881 assertions/s.
4688 runs, 20715 assertions, 7 failures, 9 errors, 3 skips

You have skipped tests. Run with --verbose for details.
Build step 'Execute shell' marked build as failure
Finished: FAILURE