Getting error when running the rake db:migrate Rails_ENV="production"

Added by Tony Sanders about 9 years ago

Hello All,

I'm trying to setup Redmine on a Windows 2003 Enterprise edition. I have installed ruby186-26, redmine-0.7.3 and I have rails-2.0.2. I have my database MYSQL 6 up and running. To give a brief idea I have executed the following commands:

ran, svn co http://redmine.rubyforge.org/svn/trunk redmine
then ran, copy database.yml.example database.yml
created a database using roots credentials, create database redmine character set utf8;
and then I tried running, rake db:migrate Rails_ENV="production" . But it gave me an error saying that rake is not recognized as an internal or external command. By the way when I ran the rake command I was in my C:\redmine-0.7.3> location.

Can someone please help me with this. I'm sure I'm doing something silly here. Please let me know as I have done a lot of research by myself and have failed to solve this issue.

Thanks

Replies (5)

RE: Getting error when running the rake db:migrate Rails_ENV="production" - Added by Thomas Lecavelier about 9 years ago

Hi Tony,

Since you install every thing from packages, you just haven't rake... So, time to install it: http://rake.rubyforge.org/

(personnaly, I prefer working with the gem app manager, which handle dependancies)

RE: Getting error when running the rake db:migrate Rails_ENV="production" - Added by Tony Sanders about 9 years ago

Thank you for you responsding.
I installed the rake using the "gem install --remote rake" and it ran just fine.
But, when I try to execute , C:\redmine-0.7.3>rake db:migrate Rails_ENV="production", it doesn't work.
Have no idea what am I missing on. Any help would be appreciated.

Thanks

RE: Getting error when running the rake db:migrate Rails_ENV="production" - Added by Mark Gordon-Bird about 9 years ago

Hi There

I am, having a similar problem. I'm fairly new to Ubuntu and looking to get Redmine up and running on Ubuntu Fiesty Fawm

I have had some success with getting the Ruby Gems installed (and Apache and MYSQL) however when it comes to running the following command I got from the Redmine Install guide I get an error. I have had several errors but got round them by diiging various forums but this one is killing me.

Can anyone point me to the right place please or tell me if you need more info.

Right this is the command I use in terminal and the prompt is "" which I think means I am under the application root directory: (I think)

sudo rake db:migrate RAILS_ENV="production"

Which starts off fine but gives me the following after I provide the password
------------------------------------------------------------------
(in /home/birdm/redmine-0.7)
rake aborted!
undefined method `rakefile' for #<Rake::Application:0xb7cc07b0>
/home/birdm/redmine-0.7/Rakefile:10
(See full trace by running task with --trace)
--------------------------------------------------------------------

If I provide --trace I get
--------------------------------------------------------------------
(in /home/birdm/redmine-0.7)
rake aborted!
undefined method `rakefile' for #<Rake::Application:0xb7c677b4>
/home/birdm/gems/gems/rake-0.8.3/lib/rake/rdoctask.rb:105:in `define'
/home/birdm/gems/gems/rake-0.8.3/lib/rake/rdoctask.rb:81:in `initialize'
/home/birdm/gems/gems/rails-2.1.1/lib/tasks/documentation.rake:3:in `new'
/home/birdm/gems/gems/rails-2.1.1/lib/tasks/documentation.rake:3
/usr/lib/ruby/1.8/rake.rb:1548:in `in_namespace'
/usr/lib/ruby/1.8/rake.rb:640:in `namespace'
/home/birdm/gems/gems/rails-2.1.1/lib/tasks/documentation.rake:1
/home/birdm/gems/gems/activesupport-2.1.1/lib/active_support/dependencies.rb:503:in `load'
/home/birdm/gems/gems/activesupport-2.1.1/lib/active_support/dependencies.rb:503:in `load'
/home/birdm/gems/gems/activesupport-2.1.1/lib/active_support/dependencies.rb:355:in `new_constants_in'
/home/birdm/gems/gems/activesupport-2.1.1/lib/active_support/dependencies.rb:503:in `load'
/home/birdm/gems/gems/rails-2.1.1/lib/tasks/rails.rb:4
/home/birdm/gems/gems/rails-2.1.1/lib/tasks/rails.rb:4:in `each'
/home/birdm/gems/gems/rails-2.1.1/lib/tasks/rails.rb:4
/usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
/usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `require'
/home/birdm/redmine-0.7/Rakefile:10
/usr/lib/ruby/1.8/rake.rb:1828:in `load'
/usr/lib/ruby/1.8/rake.rb:1828:in `load_rakefile'
/usr/lib/ruby/1.8/rake.rb:1900:in `run'
/usr/bin/rake:4
--------------------------------------------------------------------

Any and All help welcomed and appreciated and muchly needed!!

MArcus

RE: Getting error when running the rake db:migrate Rails_ENV="production" - Added by Thomas Lecavelier about 9 years ago

Gems for apache and mysql are just binding. You need to have the server behind:

sudo aptitude install apache2 mysql-server

For rake, it can be plenty of things: mess between rake gem and rake from ubuntu distro, missing file, etc.

Please read this post: http://www.redmine.org/boards/2/topics/show/667 to complete your post (next time, open a new topic, this one was quite old and unrelevant since not the same conf' at all).

(1-5/5)