Important: Ruby 1.8.7 out of support

Added by Jan Niggemann (redmine.org team member) over 1 year ago

The maintainers of the ruby language retired ruby 1.8.7 on June 30 2013. http://www.ruby-lang.org/en/news/2013/06/30/we-retire-1-8-7/

What does that mean for me as a redmine administrator?

If you're using ruby 1.8.7 in your stack, please update to a more recent version. The current versions of redmine will continue to funtion (2.3.1 and 2.2.4 at the time of writing) but future versions may drop support for ruby 1.8.7 (#14371).

Overview of ruby-packages in some distributions

Debian stable 1.9.3
Fedora Rawhide 2.0.0.195-8.fc20
Fedora 19 2.0.0.195-8.fc19
Fedora 18 1.9.3.429-30.fc18
Fedora 17 1.9.3.429-30.fc17
openSUSE 12.1 1.8.7
openSUSE 12.2 1.9.3

Some distributions will nevertheless provide security fixes backported from upstream.
Please check if this applies to your distribution.

Replies (1)

(1-1/1)