One more email setup error..

Added by clawfrown clawfrown over 9 years ago

I'm completely stuck in trying to setup redmine to send mail on our server machine, though it works well on my laptop debug redmine environment.

1. Redmine sends emails well on my MacOS laptop - environment.rb smtp setting are following:

    config.action_mailer.raise_delivery_errors = true
    config.action_mailer.smtp_settings = {
        :address => "mail.mydomain.com",
        :port => 25,
        :domain => "mydomain.com",
        :expires => 60,
        :authentication => :login,
        :user_name => "username",
        :password => "password" 
    }
    config.action_mailer.perform_deliveries = true

2. Redmine setup on Windows server 2003 (our office server machine) works well in all aspects, but don't send emails (it hangs for a while and finally prints error when I try to send test_mail):

(An existing connection was forcibly closed by the remote host.)

In solving this I tried to send mail via Outlook Express on our server machine using smtp settings i provide to redmine. And it works well only if I check "My server requires authentication" under "Outgoing Mail Server" setting in "Servers" tab of my account properties. If i don't check that up - it hangs and says something about "HELO/EHLO settings" etc..

I suppose redmine smtp should be configured somehow similar to this setting: "My server requires authentication".. :-| Or.. Is it something in Windows Server?

Is that ":pop3_auth => " problem? (btw, got an error when tried to setup it like in #1379).

Replies (5)

RE: One more email setup error.. - Added by Thomas Lecavelier over 9 years ago

Hi,

Failure 1: you forget to tell us what redmine version you're using. In devel branch, email settings are deported from config/environment.rb to config/email.yml
Failure 2: SMTP client use the :domain value to set the HELO/EHLO SMTP command
Failure 3: you don't explain where is your smtp server and what it is (even if I fear it MS Exchange...)

If both are on the same server, just take it easy: assuming that local SMTP messages sent from intranet don't require authentication, just comment out every lines in smtp config but the server, port and maybe domain.

RE: One more email setup error.. - Added by clawfrown clawfrown over 9 years ago

Hi Thomas, thanks for reply. Sorry for lack of info..

1. Redmine 7.01rc1
2. Honestly, I'm not good in "mail setup" so don't know what that mean (and don't interested much - I just want redmine to send emails.. ;-) )
3. SMTP server is external, in internet - under our hosting/domain registrant. And I didn't understand the question "What is it?" As far as I know our hosting provider uses linux on their servers.. I don't think it's so important - coz smpt settings are the same as on my laptop and on office server (and redmine installation is identical), the difference is just system (MacOS vs Windows Server).

BTW, If I comment login and password it doesn't hang but says error: (550 Forged hostname detected in HELO).

RE: One more email setup error.. - Added by clawfrown clawfrown over 9 years ago

Maybe that can help to understand:

If I uncheck "My server requires authentication" checkbox in Outlook Express settings - it says this error:
The message could not be sent because one of the recipients was rejected by the server. Server Response: 550 Your HELO/EHLO must be contain FQDN or literal adress(RFC-2821).

RE: One more email setup error.. - Added by clawfrown clawfrown over 9 years ago

Update: I've checked telnet command - everything fine.. could send correctly the message..

RE: One more email setup error.. - Added by clawfrown clawfrown over 9 years ago

Just wanted to say that I defeated that error.. In case somebody would face it..

I completely removed any kind of IIS on the Windows Server box, then installed local smtp server there (http://www.softkeeper.com/5starmailsrv.html), setup gateway on that server = so it relays the mail directly on our ISP smtp with login and password used for mail account. Then wrote environment.rb as described in #1379 (though not sure it's necessary - the main thing is to write :adress => "localhost" if using local smtp server..

Huh.. It was hard.. damn windows server..
But now it works and I'm the happiest man on the planet! :-)

(1-5/5)