./dispatch.fcgi creates Error -- fcgi (LoadError)

Added by Dirk Rennekamp over 1 year ago

Hi together,

I know there are already some entries regarding this problem. But the described solutions as well as extensive external search did't help me:-(

I am using:

FreeBSD 8.1,
redmine v2.03,
gem 1.8.24,
ruby 1.9.3.p194,
mod_fastcgi-2.4.6,
fcgi-2.4.1-SNAP-0311112127 and
gem fcgi (0.8.8)

I installed the gem fcgi with the "FreeBSD-Options" like this:
gem install fcgi -- --with-fcgi-include=/usr/local/include --with-fcgi-lib=/usr/local/lib
My dispatch.fcgi in the redmine/public starts with this:

#!/usr/local/bin/ruby

require 'rubygems'
require 'fcgi'

So on the commandline to execute ./dispatch.fcgi gives this report:

/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `block in require': iconv will be deprecated in the future, use String#encode instead.
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `require': cannot load such file -- fcgi (LoadError)
from /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `block in require'
from /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:236:in `load_dependency'
from /usr/local/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `require'
from /usr/local/lib/ruby/gems/1.9.1/gems/rack-1.4.1/lib/rack/handler/fastcgi.rb:1:in `<top (required)>'
from ./dispatch.fcgi:26:in `<main>'

I would appreciate any usefull help- got stuck since three days with this problem

Thanks
Dirk

Replies (1)

(1-1/1)