Response not received from FastCGI process

Added by Blaine LaFreniere over 10 years ago

I'm trying to setup Redmine with LightTPD + PostgreSQL + FastCGI.

I'm receiving the following errors in log/lighttpd.error.log:

2009-03-01 04:07:17: (mod_fastcgi.c.2494) unexpected end-of-file (perhaps the fastcgi process died): pid: 6583 socket: unix:/tmp/redmine.sock-3
2009-03-01 04:07:17: (mod_fastcgi.c.3278) child exited, pid: 6583 status: 1
2009-03-01 04:07:17: (mod_fastcgi.c.3292) --- fastcgi spawning
    socket unix:/tmp/redmine.sock-3
    current: 1 / 4
2009-03-01 04:07:17: (mod_fastcgi.c.814) new proc, socket: 0 /tmp/redmine.sock-3
2009-03-01 04:07:17: (mod_fastcgi.c.3325) response not received, request sent: 1050 on socket: unix:/tmp/redmine.sock-3 for /dispatch.fcgi , closing connecti
2009-03-01 04:07:17: (mod_fastcgi.c.1515) released proc: pid: 6585 socket: unix:/tmp/redmine.sock-3 load: 0

When I try to access redmine via firefox, I receive the error message: "500 - Internal Server Error." I've already checked over at the LightTPD and there are roughly 6 or 7 unanswered forum posts with similar errors.

Below I have put my configs/versions/permissions/etc

Any help is appreciated, thanks.

config:

$HTTP["host"] == "redmine.jacolyte.com" {
    server.document-root     = "/home/blaine/devel/ruby/redmine/public" 
    server.follow-symlink    = "enable" 

    alias.url = ()

    server.indexfiles = ( "dispatch.fcgi" )
    server.error-handler-404 = "/home/blaine/devel/ruby/redmine/public/dispatch.fcgi" 

    server.errorlog          = "/home/blaine/devel/ruby/redmine/log/lighttpd.error.log" 
    accesslog.filename       = "/home/blaine/devel/ruby/redmine/log/lighttpd.access.log" 

    url.rewrite = (
        "^/(.*\..+(?!html))$" => "$0",
        "^/(.*)\.(.*)"        => "$0",
    )

    fastcgi.server      = ( ".fcgi" => ( "localhost" => (
        "min-procs"       => 1,
        "max-procs"       => 4,
        "idle-timeout"  => 120,
        "socket"          => "/tmp/redmine.sock",
        "check-local"       => "disable",
        "bin-path"        => "/usr/bin/ruby /home/blaine/devel/ruby/redmine/public/dispatch.fcgi",
        "bin-environment" => ( "RAILS_ENV" => "production" )
    ) ) )

    $HTTP["useragent"] =~ "^(.*MSIE.*)|(.*AppleWebKit.*)$" {
        server.max-keep-alive-requests = 0
    }
}

Permissions:

ivan redmine # ls -al
total 68
drwxr-xr-x 16 lighttpd lighttpd 4096 Mar  1 02:41 .
drwxr-xr-x  3 blaine   blaine   4096 Mar  1 02:41 ..
drwxr-xr-x  6 lighttpd lighttpd 4096 Mar  1 02:41 .svn
-rw-r--r--  1 lighttpd lighttpd  307 Mar  1 02:41 Rakefile
drwxr-xr-x  8 lighttpd lighttpd 4096 Mar  1 02:41 app
drwxr-xr-x  6 lighttpd lighttpd 4096 Mar  1 02:41 config
drwxr-xr-x  4 lighttpd lighttpd 4096 Mar  1 02:45 db
drwxr-xr-x  3 lighttpd lighttpd 4096 Mar  1 02:41 doc
drwxr-xr-x  6 lighttpd lighttpd 4096 Mar  1 02:41 extra
drwxr-xr-x  3 lighttpd lighttpd 4096 Mar  1 02:41 files
drwxr-xr-x  8 lighttpd lighttpd 4096 Mar  1 02:41 lib
drwxr-xr-x  3 lighttpd lighttpd 4096 Mar  1 04:25 log
drwxr-xr-x  9 lighttpd lighttpd 4096 Mar  1 02:55 public
drwxr-xr-x  5 lighttpd lighttpd 4096 Mar  1 02:41 script
drwxr-xr-x  8 lighttpd lighttpd 4096 Mar  1 02:41 test
drwxr-xr-x  7 lighttpd lighttpd 4096 Mar  1 03:20 tmp
drwxr-xr-x  5 lighttpd lighttpd 4096 Mar  1 02:41 vendor

# in public/
-rwxr-xr-x  1 lighttpd lighttpd  859 Mar  1 02:54 dispatch.fcgi

# in /tmp/
srwxr-xr-x  1 lighttpd lighttpd    0 Mar  1 04:27 redmine.sock-0
srwxr-xr-x  1 lighttpd lighttpd    0 Mar  1 04:27 redmine.sock-1
srwxr-xr-x  1 lighttpd lighttpd    0 Mar  1 04:27 redmine.sock-2
srwxr-xr-x  1 lighttpd lighttpd    0 Mar  1 04:27 redmine.sock-3

Ruby version:

ivan tmp # ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [x86_64-linux]

Rails version:

ivan tmp # rails --version
Rails 2.2.2

System info:

ivan tmp # uname -a
Linux ivan 2.6.24-19-xen #1 SMP Wed Aug 20 21:08:51 UTC 2008 x86_64 Dual-Core AMD Opteron(tm) Processor 2212 AuthenticAMD GNU/Linux

Web Server:

lighttpd-1.4.20 (ssl) - a light and fast webserver
Build-Date: Feb 28 2009 01:17:47

Database:

ivan tmp # postgres --version
postgres (PostgreSQL) 8.3.1