Redmine 3.2 on Ubuntu 10.04

Added by Tom B over 1 year ago

Hi,
on an old server I'm still running Ubuntu 10.04 (with plans on updating soon) and I'd like to upgrade to Redmine 3.2 there.
Right now I'm running 2.6.9.
In RedmineInstall it says it required Ruby 2.2 (which I managed to install) and runs on Rails 4.2
The latter does not really seem to be a requirement but I'm not sure about it so I'm asking here to clarify that.

If it is a requirement I have no clue how to upgrade to 4.2 since the latest available version for 10.04 seems to be 2.2.3 which is installed right now.

Replies (1)

RE: Redmine 3.2 on Ubuntu 10.04 - Added by Martin Denizet (redmine.org team member) over 1 year ago

Hello,
It's because you're using the Ubuntu package.
To always be able to run the latest version, it's easier to have a custom install (not using the distro package).
As you can see here , Redmine 3.2.1 package is available on Ubuntu 16.04.
You might want to have a look at the backports.
If I were you, I'd be doing a custom install using RVM but it can look a bit technical.
Good luck!

(1-1/1)