Plugin Budget Error || installing ||

Added by Sofia Moon 12 months ago

Hi,

I'm having a problem installing budget plugin, I've installed today the rate plugin sucessfully, but when I try to install budget, the following error appears:

[smoon@localhost current]# rake redmine:plugins:migrate RAILS_ENV=production --trace
** Invoke redmine:plugins:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
Exception: ERROR: The Rate plugin is not installed.  Please install the Rate plugin from https://projects.littlestreamsoftware.com/projects/redmine-rate

The thing is.. Rate is already installed, here is my redmine info:

Environment:
  Redmine version                3.4.2.stable
  Ruby version                       2.2.6-p396 (2016-11-15) [x86_64-linux]
  Rails version                        4.2.8
  Environment                       production
  Database adapter              Mysql2
SCM:
  Subversion                          1.7.14
  Git                                          1.8.3.1
  Filesystem                     
Redmine plugins:
  easy_gantt                            1.8
  redmine_agile                     1.4.4
  redmine_checklists             3.1.6
  redmine_contacts               4.1.1
  redmine_contacts_invoices      4.1.6
  redmine_create_git             0.2.0
  redmine_finance                2.1.3
  redmine_helpdesk               0.0.15
  *redmine_rate                   1.0.0*

What I'm I doing wrong? I've changed the directory name from redmine-budget-plugin-master to redmine_budget, it has the right permissions, what am I missing here?
I've downloaded budget from 2 different versions to see if any would work, but they both give me the same error
link1: github.com/konradb3/redmine-budget-plugin
link2: github.com/edavis10/redmine-budget-plugin

Thank you very much for the help,
Best regards,
Sferreira

Replies (3)

RE: Plugin Budget Error || installing || - Added by Ben Blanco 5 months ago

Hi Sofia,

did you find a solution to this?

I have just tried using `redmine-3.1` branch of both these plugins, from here

https://github.com/LOUISINTERNET/redmine-budget-plugin
https://github.com/LOUISINTERNET/redmine_rate/

But redmine-budget fails to install on latest redmine v3.4.4

If you figured out a solution, please update/share what you found.

Thanks!

RE: Plugin Budget Error || installing || - Added by Sofia Moon 5 months ago

Hey,

Jesus I've just received an email about this in my inbox, I had totally forgotten about it.

But no Ben :/ I had not luck installing budget plugin on my Server, wish I had, we had to go for a different solution instead of redmine because this was urgent.

I was able to install only the following;
- Easy Gantt;
- Checklists;
- CRM;
- Invoices;
- Create;
- Finance;
- Helpdesk;
- Rate;
- Reports (although this one had an error too, was able to install it, but my users were experiencing an error with it);
- Work Time.

No luck with it :/ sorry

RE: Plugin Budget Error || installing || - Added by Ben Blanco 5 months ago

No prob. Thanks for the info/feedback ;)

(1-3/3)