Many mistakes in source files when upgrading

Added by Filip Skorna about 1 month ago

Hello to everybody,
I have a problem with uprading our easyredmine from version 3.3.0 to 3.3.2

The final step (bundle exec rake easyproject:install RAILS_ENV=production) give me this output:

Invoking generate_secret_token...
Invoking change_plugins_order...
Invoking clearing session...
Support of Ruby version lower than 2.3 will be dropped in 2017
rake aborted!
NameError: uninitialized constant LdapSync
/azor/easyredmine/plugins/redmine_ldap_sync/init.rb:9:in `block in <top (required)>'
/azor/easyredmine/plugins/easyproject/init.rb:146:in `instance_eval'
/azor/easyredmine/plugins/easyproject/init.rb:146:in `register'
/azor/easyredmine/plugins/redmine_ldap_sync/init.rb:3:in `<top (required)>'
/azor/easyredmine/plugins/easyproject/init.rb:404:in `load_plugin_init'
/azor/easyredmine/plugins/easyproject/init.rb:390:in `block in load_all_plugins'
/azor/easyredmine/plugins/easyproject/init.rb:389:in `each'
/azor/easyredmine/plugins/easyproject/init.rb:389:in `load_all_plugins'
/azor/easyredmine/plugins/easyproject/init.rb:358:in `init!'
/azor/easyredmine/plugins/easyproject/init.rb:409:in `<top (required)>'
/azor/easyredmine/config/initializers/22-change_plugins_order.rb:15:in `load'
/azor/easyredmine/config/initializers/30-redmine.rb:21:in `<top (required)>'
/usr/local/rvm/gems/ruby-2.2.2/gems/railties-4.2.7.1/lib/rails/engine.rb:652:in `block in load_config_initializer'
/usr/local/rvm/gems/ruby-2.2.2/gems/activesupport-4.2.7.1/lib/active_support/notifications.rb:166:in `instrument'
/usr/local/rvm/gems/ruby-2.2.2/gems/railties-4.2.7.1/lib/rails/engine.rb:651:in `load_config_initializer'
/usr/local/rvm/gems/ruby-2.2.2/gems/railties-4.2.7.1/lib/rails/engine.rb:616:in `block (2 levels) in <class:Engine>'
/usr/local/rvm/gems/ruby-2.2.2/gems/railties-4.2.7.1/lib/rails/engine.rb:615:in `each'
/usr/local/rvm/gems/ruby-2.2.2/gems/railties-4.2.7.1/lib/rails/engine.rb:615:in `block in <class:Engine>'
/usr/local/rvm/gems/ruby-2.2.2/gems/railties-4.2.7.1/lib/rails/initializable.rb:30:in `instance_exec'
/usr/local/rvm/gems/ruby-2.2.2/gems/railties-4.2.7.1/lib/rails/initializable.rb:30:in `run'
/usr/local/rvm/gems/ruby-2.2.2/gems/railties-4.2.7.1/lib/rails/initializable.rb:55:in `block in run_initializers'
/usr/local/rvm/gems/ruby-2.2.2/gems/railties-4.2.7.1/lib/rails/initializable.rb:44:in `each'
/usr/local/rvm/gems/ruby-2.2.2/gems/railties-4.2.7.1/lib/rails/initializable.rb:44:in `tsort_each_child'
/usr/local/rvm/gems/ruby-2.2.2/gems/railties-4.2.7.1/lib/rails/initializable.rb:54:in `run_initializers'
/usr/local/rvm/gems/ruby-2.2.2/gems/railties-4.2.7.1/lib/rails/application.rb:352:in `initialize!'
/azor/easyredmine/config/environment.rb:14:in `<top (required)>'
/usr/local/rvm/gems/ruby-2.2.2/gems/railties-4.2.7.1/lib/rails/application.rb:328:in `require_environment!'
/usr/local/rvm/gems/ruby-2.2.2/gems/railties-4.2.7.1/lib/rails/application.rb:457:in `block in run_tasks_blocks'
/azor/easyredmine/plugins/easyproject/easy_plugins/easy_extensions/lib/tasks/installer.rake:75:in `block (2 levels) in <top (required)>'
/usr/local/rvm/gems/ruby-2.2.2/gems/rake-12.0.0/exe/rake:27:in `<top (required)>'
/usr/local/rvm/gems/ruby-2.2.2/bin/ruby_executable_hooks:15:in `eval'
/usr/local/rvm/gems/ruby-2.2.2/bin/ruby_executable_hooks:15:in `<main>'
Tasks: TOP => easyproject:install_with_environment => environment

All steps before have finished properly, I checked requirements for this version as well so that should be all right.
--------------
ruby 2.2.2p95
Rails 4.2.7.1
Bundler version 1.15.4
rake, version 12.0.0

Anybody encounter similar problem or can possibly give me some hint what to do or where can be a problem ?

Thanks in advance :)