Not able to link git repositories to redmine, Error in the Settings page when I want to enable Git

Added by Philippe Desgroseilliers 3 months ago

Good Afternoon,

First post here so I hope I don't break any rules. I checked previous posts to see if my issue had been resolved before but I couldn't seem to find anything so hopefully someone can help me.

The server Redmine is installed on is running Windows Server 2008 without cygwin.
(I've attached all other software info in the text file)

My department at work has been using Redmine to manage their SVN projects for a few years now and have had no problems. More recently, people have been trying to make a case to switch to a GIT server to store their projects so I was given the job and look in to it. I set up a GIT server on our server at work and that works fine but I can't seem to integrate it to Redmine. When I go to the settings page in Redmine there is a warning when I go to enable GIT. I looked in the configuration.yml folder on our work server and added several different paths, restarting redmine after every change, and none of them took the warning away. I then tried reverting the config file to it's original state and changing the Environment Variables on the Server to add a path towards Git.exe (C:\Program Files\Git\bin) but to no avail. I've uninstalled and reinstalled GIT on the server to see if that would change anything but again nothing changed. The only thing I haven't tried is reinstalling Redmine completely but I can't really do that without screwing the whole department over.

Is there something I'm missing? I did see that Redmine 3.3.3 doesn't officially support git 2.14.1 but I didn't think that would be an issue.

Any help would be appreciated
Thank you

-Philippe D.

RAILS_ENV.txt Magnifier - Output for $RAILS_ENV=development bin/about (1.93 KB)