How to find out what Redmine version plugin was wrote and tested against?

Added by Yuriy Silvestrov over 8 years ago

I have found out that half of the plugins I have tested are not working against production release of Redmine (0.8.3). May be some of them are buggy, but others should be using with trunc version only.
Should we have any kind of mechanism to find out if this plugin is compatible with particular Redmine version (or at least with latest stable release)? I do not care if it is just a table on Wiki page or some messages during the migration; but being a user of Redmine I will find it extremely helpful.

Replies (2)

RE: How to find out what Redmine version plugin was wrote and tested against? - Added by Jason Messmer over 8 years ago

I think long term should be to setup a continuous integration server, hudson :), and execute jobs per baseline with the requirement of plug-ins should contain test cases.

RE: How to find out what Redmine version plugin was wrote and tested against? - Added by Eric Davis over 8 years ago

Some plugins are now using the `requires_redmine :version` API which will check that the version of Redmine. It will take a bit until all plugins are using that and all Redmine installs are upgraded to support it.

Jason Messmer wrote:

I think long term should be to setup a continuous integration server, hudson :), and execute jobs per baseline with the requirement of plug-ins should contain test cases.

I have a continuous integration server setup for my plugins but I still have some work to do before it will test using both the trunk and stable version of Redmine.

Eric

(1-2/2)