Defect #20591

PDF export does not determine picture (.png) height correctly

Added by Marwijn Hessel over 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:PDF export
Target version:2.6.8
Resolution:Fixed Affected version:3.1.0

Description

When exporting a redmine page as PDF. Somehow the height of pictures (.png) is not determined correctly. When there are more pictures on a page, in the PDF export these are laying on top of each other (see example in attachment).

on-top.png (202 KB) Marwijn Hessel, 2015-08-21 14:03

Vocam_IDE_Logging.png (8.3 KB) Marwijn Hessel, 2015-09-15 08:24

ExampleProjectEditing.png (105 KB) Marwijn Hessel, 2015-09-15 08:24

Associated revisions

Revision 14813
Added by Toshi MARUYAMA about 2 years ago

update rbpdf version to 1.18.7 (#20591, #20811)

Revision 14814
Added by Toshi MARUYAMA about 2 years ago

Merged r14813 from trunk to 3.1-stable (#20591, #20811)

update rbpdf version to 1.18.7.

Revision 14815
Added by Toshi MARUYAMA about 2 years ago

Merged r14813 from trunk to 3.0-stable (#20591, #20811)

update rbpdf version to 1.18.7.

Revision 14816
Added by Toshi MARUYAMA about 2 years ago

Merged r14813 from trunk to 2.6-stable (#20591, #20811)

update rbpdf version to 1.18.7.

History

#1 Updated by Toshi MARUYAMA over 2 years ago

  • Status changed from New to Confirmed

#2 Updated by Jun NAITOH over 2 years ago

Marwijn Hessel wrote:

When exporting a redmine page as PDF.
Somehow the height of pictures (.png) is not determined correctly.
When there are more pictures on a page, in the PDF export these are laying on top of each other (see example in attachment).

I can't reproduced.
Can you have reproduced pictures?

#3 Updated by Marwijn Hessel over 2 years ago

There is no relation with the used pictures and this issue.
When exporting to PDF the height of any picture is incorrect.
Sometimes they will be placed on top of each other, sometimes there is one picture per page (when multiple does fit).
I tried different picture formats (like BMP, JPG, PNG), it does not change a thing ...

When looking into the produced HTML code of redmine, the picture height (and width) is not mentioned in the <img> tag. Which should be accordingly to W3C (http://www.w3schools.com/tags/tag_img.asp).
This is only guessing if this has any relation with this issue (but it is no correct HTML).

When printing the page all goes well, pictures are on the place where they should be.

#4 Updated by Jun NAITOH over 2 years ago

I reproduced this problem.
This is the bug of rbpdf with PNG alpha channel picture.

#5 Updated by Jun NAITOH about 2 years ago

This problem fixed by rbpdf 1.18.7.
please bundle update.

#6 Updated by Toshi MARUYAMA about 2 years ago

  • Priority changed from Urgent to Normal
  • Target version set to 2.6.8

#7 Updated by Toshi MARUYAMA about 2 years ago

  • Status changed from Confirmed to Closed
  • Resolution set to Fixed

I have updated rbpdf to 1.18.7 in trunk, 3.1-stable, 3.0-stable and 2.6-stable, thanks.

Also available in: Atom PDF