Defect #23182

url in email + sub uri = sub uri duplication

Added by Evgeniy Dushistov over 1 year ago. Updated over 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Email notifications
Target version:-
Resolution:Duplicate Affected version:3.2.1

Description

I configure redmine to be https://server/redmine via

RedmineApp::Application.routes.default_scope =  { :path => '/redmine', :shallow_path => '/redmine' }
#RedmineApp::Application.routes.default_scope = "/redmine" 
# Initialize the Rails application
Rails.application.initialize!
Redmine::Utils::relative_url_root = "/redmine" 

all works fine, except links in email - they looks like:
https://server/redmine/redmine/issues/1#change-31

I have set hostname to server, and protocol to https via
Administration->Preference->General


Related issues

Duplicates Redmine - Defect #20192: IssueLink in email notification contains SUB-URI part twice Needs feedback

History

#1 Updated by Toshi MARUYAMA over 1 year ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #20192.
Try #20192#note-4.

#2 Updated by Toshi MARUYAMA over 1 year ago

  • Duplicates Defect #20192: IssueLink in email notification contains SUB-URI part twice added

Also available in: Atom PDF