Defect #23420

Error 500 whhen access to activity page of one project

Added by Jean Louis about 1 year ago. Updated about 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Activity view
Target version:-
Resolution:Invalid Affected version:3.3.0

Description

Version Redmine 3.3.0.devel.15732

Access to the activity page says internal error.

The production.log says :

Started GET "/projects/xxxx/activity" for xxxx at 2016-07-25 09:17:02 +0200
Processing by ActivitiesController#index as HTML
  Parameters: {"id"=>"xxxx"}
  Current user: xxxx (id=4)
  Rendered plugins/redmine_my_page/app/views/activities/esi.html.erb within layouts/base (819.7ms)
Completed 500 Internal Server Error in 1766ms (ActiveRecord: 47.7ms)

ActionView::Template::Error (undefined method `link_to_content_update' for #<#<Class:0x007f7a465c6760>:0x0000000ab849f8>):
    22: <%= content_tag('p', l(:label_no_data), :class => 'nodata') if @events_by_day.empty? %>
    23:
    24: <div style="float:left;">
    25: <%= link_to_content_update("\xc2\xab " + l(:label_previous),
    26:                    params.merge(:from => @date_to - @days - 1),
    27:                    :title => l(:label_date_from_to, :start => format_date(@date_to - 2*@days), :end => format_date(@date_to - @days - 1)),
    28:                    :accesskey => accesskey(:previous)) %>
  plugins/redmine_my_page/app/views/activities/esi.html.erb:25:in `_0a5d68e156dc6329c172caa2c15a931c'
  plugins/redmine_my_page/lib/my_page_patches/activities_controller_patch.rb:71:in `block (2 levels) in index_with_esi'
  plugins/redmine_my_page/lib/my_page_patches/activities_controller_patch.rb:65:in `index_with_esi'
  lib/redmine/sudo_mode.rb:63:in `sudo_mode'
  plugins/redmine_dmsf/lib/redmine_dmsf/webdav/no_parse.rb:33:in `call'

The problem is in DMSF plugin or in redmine ?

History

#1 Updated by Jean Louis about 1 year ago

Maybe a problem with my redmine tree, I don't reproduce on similar context on other machine.

#2 Updated by Toshi MARUYAMA about 1 year ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Please contact plugin author.

Also available in: Atom PDF