Defect #27079

cannot chose multiple value for a custom field

Added by Randa Bustami 3 months ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Custom fields
Target version:-
Resolution:Invalid Affected version:

Description

i had added custom field type" list" and activate multiple values check box but when i tried to chose 2 values it display server error
but when i chose one value it save the setting
attached the custom field setting

multiple selection field.PNG (46.2 KB) Randa Bustami, 2017-09-26 13:42

cf.png (4.43 KB) Toshi MARUYAMA, 2017-09-26 16:40

error messege.PNG - logfile (53.5 KB) Randa Bustami, 2017-09-27 07:58

testing field.PNG (6.03 KB) Randa Bustami, 2017-09-27 08:05

History

#1 Updated by Toshi MARUYAMA 3 months ago

  • File cf.png added
  • Category set to Custom fields
  • Status changed from New to Needs feedback

I cannot reproduce on vanilla Redmine 3.4.2.

#2 Updated by Randa Bustami 3 months ago

what i did is added custom field to the user fields
the type of the new field is " list" with multiple values option activated.
when i update user information and chose one value it save the changes without any problem but when i tried to chose 2 values it give me below error message:
" Internal error

An error occurred on the page you were trying to access.
If you continue to experience problems please contact your Redmine administrator for assistance.

If you are the Redmine administrator, check your log files for details about the error.

Back"

#3 Updated by Randa Bustami 3 months ago

kindly check the attached screen shot from the log file where it said it must be unique value
that mean the multiple value option is not activated

#4 Updated by Randa Bustami 3 months ago

i had added new custom field type" list "and activate multiple values option but still give the same error (pls check attached screen shot)

#5 Updated by Toshi MARUYAMA 3 months ago

I cannot reproduce in users custom field on vanilla Redmine 3.4.2.
Try without plugins.

#6 Updated by Randa Bustami 3 months ago

this issue is solved
our system admin put validation at Db to except one value only !
you can close the issue
many thanks

#7 Updated by Toshi MARUYAMA 3 months ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Invalid

Also available in: Atom PDF