Error after update

Added by Han Dijk over 8 years ago

After i updated to the latest dev version i get a 500 internal server error on /login, in apache log files it says

Status: 500 Internal Server Error
undefined method `set_cookie_header!' for Rack::Utils:Module

Any ideas on how to solve this??

Replies (9)

RE: Error after update - Added by Han Dijk over 8 years ago

anyone please?

RE: Error after update - Added by Jason van Dyk over 8 years ago

Has a solution been found yet? I get the same error.

RE: Error after update - Added by Han Dijk over 8 years ago

I switched from trunk to the latest stable release, that fixed the issue...

RE: Error after update - Added by Jason van Dyk over 8 years ago

I tried all that and it didn't work for me.... Are you using Apache or Webrick?

I found that I can use the current trunk revision, providing I'm running under webrick.

RE: Error after update - Added by Jason van Dyk over 8 years ago

PS I've added an issue #8052

RE: Error after update - Added by Han Dijk over 8 years ago

I'm also running Redmine in Apache

RE: Error after update - Added by Etienne Massip over 8 years ago

Upgrade Rack to 1.1.0, see RedmineInstall.

RE: Error after update - Added by Jason van Dyk over 8 years ago

Already tried upgrading Rack to 1.1.0.

RE: Error after update - Added by Jason van Dyk over 8 years ago

Ok the real solution, at least the one that worked for my situation is that passenger needs to be upgrade from 2.2.4. As far as I've seen none of the HowTo's or version documents requirements such as RedmineInstall list a version dependency of Passenger.

(1-9/9)