Ruby on Rails application could not be started

Added by Jakub Semko almost 9 years ago

Please, I wanted to install the plugin and I have followed this http://www.redmine.org/wiki/redmine/Plugins but I do not know what happened and now when I want to open Redmine, I have this error, please reply, I do not know how continue.

Ruby on Rails application could not be started
A source file that the application requires, is missing.

*
It is possible that you didn't upload your application files correctly. Please check whether all your application files are uploaded. *
A required library may not installed. Please install all libraries that this application requires.

Further information about the error may have been written to the application's log file. Please check it in order to analyse the problem.

Error message:
no such file to load -- application (MissingSourceFile)
Exception class:
PhusionPassenger::UnknownError
Application root:
/usr/local/lib/redmine-0.9
Backtrace: # File Line Location
0 /usr/lib/ruby/1.8/rubygems/custom_require.rb 31 in `gem_original_require'
1 /usr/lib/ruby/1.8/rubygems/custom_require.rb 31 in `require'
2 /var/lib/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb 158 in `require'
3 /usr/local/lib/redmine-0.9/vendor/plugins/redmine_local_avatars/lib/users_avatar_patch.rb 1
4 /usr/lib/ruby/1.8/rubygems/custom_require.rb 31 in `gem_original_require'
5 /usr/lib/ruby/1.8/rubygems/custom_require.rb 31 in `require'
6 /var/lib/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb 158 in `require'
7 /usr/local/lib/redmine-0.9/vendor/plugins/redmine_local_avatars/init.rb 3 in `evaluate_init_rb'
8 /var/lib/gems/1.8/gems/rails-2.3.5/lib/rails/plugin.rb 158 in `evaluate_init_rb'
9 /var/lib/gems/1.8/gems/activesupport-2.3.5/lib/active_support/core_ext/kernel/reporting.rb 11 in `silence_warnings'
10 /var/lib/gems/1.8/gems/rails-2.3.5/lib/rails/plugin.rb 154 in `evaluate_init_rb'
11 /var/lib/gems/1.8/gems/rails-2.3.5/lib/rails/plugin.rb 48 in `load'
12 /usr/local/lib/redmine-0.9/config/../vendor/plugins/engines/lib/engines/plugin.rb 44 in `load'
13 /var/lib/gems/1.8/gems/rails-2.3.5/lib/rails/plugin/loader.rb 38 in `load_plugins'
14 /var/lib/gems/1.8/gems/rails-2.3.5/lib/rails/plugin/loader.rb 37 in `each'
15 /var/lib/gems/1.8/gems/rails-2.3.5/lib/rails/plugin/loader.rb 37 in `load_plugins'
16 /var/lib/gems/1.8/gems/rails-2.3.5/lib/initializer.rb 369 in `load_plugins'
17 /var/lib/gems/1.8/gems/rails-2.3.5/lib/initializer.rb 165 in `process'
18 /var/lib/gems/1.8/gems/rails-2.3.5/lib/initializer.rb 113 in `send'
19 /var/lib/gems/1.8/gems/rails-2.3.5/lib/initializer.rb 113 in `run'
20 /usr/local/lib/redmine-0.9/config/environment.rb 20
21 /usr/lib/ruby/1.8/rubygems/custom_require.rb 31 in `gem_original_require'
22 /usr/lib/ruby/1.8/rubygems/custom_require.rb 31 in `require'
23 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/railz/application_spawner.rb 299 in `preload_application'
24 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/railz/application_spawner.rb 248 in `initialize_server'
25 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/utils.rb 255 in `report_app_init_status'
26 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/railz/application_spawner.rb 233 in `initialize_server'
27 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/abstract_server.rb 194 in `start_synchronously'
28 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/abstract_server.rb 163 in `start'
29 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/railz/application_spawner.rb 209 in `start'
30 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/spawn_manager.rb 262 in `spawn_rails_application'
31 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/abstract_server_collection.rb 126 in `lookup_or_add'
32 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/spawn_manager.rb 256 in `spawn_rails_application'
33 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/abstract_server_collection.rb 80 in `synchronize'
34 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/abstract_server_collection.rb 79 in `synchronize'
35 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/spawn_manager.rb 255 in `spawn_rails_application'
36 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/spawn_manager.rb 154 in `spawn_application'
37 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/spawn_manager.rb 287 in `handle_spawn_application'
38 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/abstract_server.rb 352 in `__send__'
39 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/abstract_server.rb 352 in `main_loop'
40 /usr/local/lib/passenger/passenger-2.2.9/lib/phusion_passenger/abstract_server.rb 196 in `start_synchronously'
41 /usr/local/lib/passenger/passenger-2.2.9/bin/passenger-spawn-server 61

Replies (5)

RE: Ruby on Rails application could not be started - Added by Felix Schäfer almost 9 years ago

  1. What plugin?
  2. Did you have any errors while installing the plugin (migration, …)?

The quickest way to get your redmine back up: remove the directory containing the plugin (or change its access rights so that the user running redmine can't access it anymore) and restart your redmine.

RE: Ruby on Rails application could not be started - Added by Jakub Semko almost 9 years ago

1. http://www.redmine.org/boards/3/topics/5365
2. Thank you, I did not know it, it works.

Can you please advise how the plugin install?
Sorry my English but I use google translate.

RE: Ruby on Rails application could not be started - Added by Felix Schäfer almost 9 years ago

The plugin has several issues with current redmine, sorry. The forum thread provides some help getting it to work, have a look at the thread and see if you can make it work, or ask away on that thread.

RE: Ruby on Rails application could not be started - Added by gilles robinet about 7 years ago

Thank you. It solves for me too.
It was the plugin redmine_schedules.

RE: Ruby on Rails application could not be started - Added by Sienna Bundey 25 days ago

Without more info it looks like you have an error in a yaml file somewhere. Perhaps there was a conflict that didn't get resolved? Do a grep on sdc_id and see what you see https://myprepaidcenter.net/

(1-5/5)