code browser

Added by Edvin Seferovic over 9 years ago

Hi,

first of all - A DAMN GOOD JOB PEOPLE !!! :)

I have been installing the whole package for a few hours now. It is working, but I cannot get code browser to work. I am using the latest redmine on Debian Etch ( svn 1.4+ ). Am I missing something?

Another idea.. wouldn't it be good if the setup script also made the branches, tags and trunks directory structure?

Thank you for help !

Regards,
E:S

Replies (3)

RE: code browser - Added by Edvin Seferovic over 9 years ago

Hi,

I just found out that code browsing is only available when the SVN is being accessed through file:/// method !

Regards,
E:S

RE: RE: code browser - Added by Justin Grevich over 9 years ago

This mysteriously works for me via HTTP occasionally. I have my SVN repo on an external host served via HTTP with digest authentication.

Initially, I tried manually fetching the change sets use the rake task, rake redmine:fetch_changesets. That still didn't help me. Then all of a sudden (I'm not aware that I changed anything) the repo browser started working yesterday. Of course, today we're back to not working again...drats :(. Also, I don't notice any reports in the log.

If anyone has any clues or theories on this erratic behavior, please post here.

Thanks,

justin

RE: code browser - Added by Justin Grevich over 9 years ago

My problem with was SELinux. I had to permit HTTP to read (using chcon -R -t httpd_sys_content_t /var/svn) from /var/svn and /etc/svn/ (where I keep my digest file and svn-access.conf).

Thanks for the great app!

justin

(1-3/3)