Installing WebDav Plugin

Added by Tom S. almost 9 years ago

Hi,

I tried to install the WebDav plugin but I don´t know how to do step "3. Configure your web server".

We have Redmine on Ruby Enterprise installed on an Ubuntu 10.04 LTS. I don´t find the file "redmine_webdav/extra/svn/RedmineAdavanced.pm" for copying into "/etc/httpd/Apache/Authn"

Where can I find this?

Replies (13)

RE: Installing WebDav Plugin - Added by Tom S. almost 9 years ago

I noticed, that either the "redmine_http_auth.git" nor the "redmine_webdav.git" will be installed.

I get no error messaeg when trying to install, only in verbose mode I see some warnings:

rubyadmin@******:/var/www/redmine-1.0.4$ sudo ruby -v script/plugin install /home/rubyadmin/redmine_http_auth.git
ruby 1.8.7 (2010-01-10 patchlevel 249) [x86_64-linux]
/usr/lib/ruby/1.8/pathname.rb:263: warning: `*' interpreted as argument prefix
/var/www/redmine-1.0.4/vendor/rails/railties/lib/commands/plugin.rb:411: warning: method redefined; discarding old plugins
/var/www/redmine-1.0.4/vendor/rails/railties/lib/commands/plugin.rb:309: warning: instance variable @rails_env not initialized
/var/www/redmine-1.0.4/vendor/rails/railties/lib/commands/plugin.rb:309: warning: instance variable @rails_env not initialized
/var/www/redmine-1.0.4/vendor/rails/railties/lib/commands/plugin.rb:309: warning: instance variable @rails_env not initialized
/var/www/redmine-1.0.4/vendor/rails/railties/lib/commands/plugin.rb:309: warning: instance variable @rails_env not initialized
/var/www/redmine-1.0.4/vendor/rails/railties/lib/commands/plugin.rb:309: warning: instance variable @rails_env not initialized
/var/www/redmine-1.0.4/vendor/rails/railties/lib/commands/plugin.rb:309: warning: instance variable @rails_env not initialized

Can anybody explain what´s wrong there?

RE: Installing WebDav Plugin - Added by Arnaud Martel almost 9 years ago

Hi,
Here is the correct url of the file: https://github.com/amartel/redmine_webdav/blob/master/extra/svn/RedmineAdvanced.pm
But don't forget that my instructions are for CentOS, not ubuntu (I don't know the directory where you have to copy RedmineAdvanced.pm)

Next, you can try to add RAILS_ENV="production" to your command line or use this alternate way to install plugins (instructions from the redmine site):
  1. cd /var/www/redmine-1.0.4/vendor/plugins
  2. git clone git://github.com/amartel/redmine_webdav.git
  3. cd ../..
  4. rake db:migrate_plugins RAILS_ENV="production"

Kind regards,
Arnaud

RE: Installing WebDav Plugin - Added by Tom S. almost 9 years ago

Hi Arnaud,

thank you for your reply. I have installed the plugins now. My problem is now that I don´t know if the "RedmineAdavanced.pm" can work with the Redmine wich uses only an SQLite database. The fact is that you describe to make a "redmine_webdav.conf". This .conf needs in your example an connection to an mysql database - "RedmineDSN "DBI:mysql:database=redmine;host=192.168.10.1;port=3306"" But we don´t use mysql, only sqlite.

RE: Installing WebDav Plugin - Added by Arnaud Martel almost 9 years ago

I don't use SQLite but asking google with "ubuntu perl sqlite" gave me, maybe, your answer:

RedmineDSN "dbi:SQLite:dbname=<your_sqlite_file>"

Of course, you have to install mod_perl2, DBI and DBD::SQLite with
  • aptitude install libapache-dbi-perl libapache2-mod-perl2 libdbd-sqlite3-perl

Kind regards,
Arnaud

RE: Installing WebDav Plugin - Added by Tom S. almost 9 years ago

Hi Arnaud,

thanks for your help. I´am not an expert in that topic, that´s why ...

Maybe you can help me finding out why the command RedmineDSN brings that error:

"Invalid command 'RedmineDSN', perhaps misspelled or defined by a module not included in the server configuration"

I have installed like you said - "sudo apt-get install libapache-dbi-perl libapache2-mod-perl2 libdbd-sqlite3-perl" without problems.

Maybe my config file is wrong?

<Location /redmine/webdav>
AuthType Basic
AuthName REDMINE
Require valid-user
PerlAccessHandler Apache::Authn::RedmineAdvanced::access_handler
PerlAuthenHandler Apache::Authn::RedmineAdvanced::authen_handler
RedmineDSN "DBI:SQLite:dbname=db/redmine.sqlite3"
RedmineAuthenticationOnly "On"
Order allow,deny
Allow from 127.0.0.1
Satisfy Any
</Location>

I also tried it with the complete path to the database and much more but no luck.

Best regards, Tom

RE: Installing WebDav Plugin - Added by Arnaud Martel almost 9 years ago

Tom,

It sounds like apache didn't load RedmineAdvanced.pm...

Did you add something like :
PerlLoadModule Apache2::Authn::RedmineAdvanced

in your config file (before the Location directive)??

RE: Installing WebDav Plugin - Added by Tom S. almost 9 years ago

Yes, it seems that the RedmineAdvanced.pm could not be found. I have already copied into /usr/lib/perl5/Apache2/RedmineAdvanced.pm but this doesn´t seems to be the right place.

With "PerlLoadModule Apache2::Authn::RedmineAdvanced" I get the error:

Can't locate Apache2/Authn/RedmineAdvanced.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl . /etc/apache2) at (eval 2) line 3.\n

But I don´t have a directory Apache2/Authn/...

RE: Installing WebDav Plugin - Added by Tom S. almost 9 years ago

I have copied the RedmineAdvanced.pm in different folders but it does not help.

/usr/lib/perl5/Apache2/RedmineAdvanced.pm
/usr/lib/perl5/RedmineAdvanced.pm
/var/www/redmine-1.0.4/vendor/plugins/redmine_webdav/extra/svn/RedmineAdvanced.pm

RE: Installing WebDav Plugin - Added by Tom S. almost 9 years ago

and to this folders:

/usr/share/perl/5.10.1/RedmineAdvanced.pm
/usr/share/perl5/RedmineAdvanced.pm
/usr/lib/perl/5.10.1/RedmineAdvanced.pm
/usr/lib/perl5/Apache2/RedmineAdvanced.pm
/usr/lib/perl5/RedmineAdvanced.pm
/var/www/redmine-1.0.4/vendor/plugins/redmine_webdav/extra/svn/RedmineAdvanced.pm
/etc/perl/RedmineAdvanced.pm

... but no luck

RE: Installing WebDav Plugin - Added by Tom S. almost 9 years ago

Hey Arnaud,

I got a hint from somebody to create a subdirectory in one of the folders e.g. /usr/share/perl/5.10/Apache2/Authn/RedmineAdvanced.pm

And indeed the error is gone but I have a new one:

Syntax error on line 1 of /etc/apache2/conf.d/redmine_webdav.conf:
Unterminated <> operator at /usr/share/perl/5.10/Apache2/Authn/RedmineAdvanced.pm line 6.\nCompilation failed in require at (eval 2) line 3.\n

Do you have an idea for that?

RE: Installing WebDav Plugin - Added by Tom S. almost 9 years ago

Ok, I got it fixed!

There was something wrong with the RedmineAdvanced.pm file. Now the Apache can start.

But opening the URL http://..../redmine/webdav gives me an Internal Error 500 (An error occurred on the page you were trying to access.)

Do you know what´s wrong there?

RE: Installing WebDav Plugin - Added by Arnaud Martel almost 9 years ago

Tom,

Great! You're on the right way...
Error 500 occurs when you try to open this url (http://.../redmine/webdav) in a web browser. That's a normal behavior and you have to use a true webdav client (see step 7 in my instructions: https://github.com/amartel/redmine_webdav).
If you still have trouble, you will find a lot of useful informations in this thread: http://www.redmine.org/boards/3/topics/18513

Kind regards,
Arnaud

RE: Installing WebDav Plugin - Added by Tom S. almost 9 years ago

Thanks for your help Arnaud, but I can not login (I tried it with Mac OS X and a WebDav Client on Windows) because after entering my credentials I get a connection error.

I will read tomorrow the thread you mentioned. I hope I will find there a solution or a good hint.

(1-13/13)