Changing localhost:3000 ??!

Added by Allan Melsen over 9 years ago

Just finished the installation of redmine, but I cant seem to make it run properly.

It's not installed on a local server, but at gatorhost which is where I host my websites.. and when I browse the site I want to use, it just displays the file dirs.

I notice that when I start it up, mongrel listens on localhost port 3000, which goes well in hand with whats configured in the settings.yml file... but even if I it in that file to be the URL of the domain I want to use.. it still starts on localhost:3000.

What am I doing wrong?

Replies (4)

RE: Changing localhost:3000 ??! - Added by Thomas Lecavelier over 9 years ago

Damn...

Redmine files have not (and should not) be in a viewable part of your server. You have to configure your webserver (apache, nginx, lighttpd, whatever) as a reverse proxy to your port 3000. See the [[HowTo_run_Redmine_with_a_Mongrel_cluster|howto|]] and your host support for this.

RE: Changing localhost:3000 ??! - Added by Antti Perkiömäki over 9 years ago

Did not install Mongrel and just using mod_proxy as reverse proxy, everything works fine except the emails. All notifications has links with the original tcp 3000 port. How can I change this port writen into emails to use http or https?

RE: Changing localhost:3000 ??! - Added by Thomas Lecavelier over 9 years ago

You should install mongrel (sudo gem install mongrel) as it's faster than webrick, and rails use it when installed without your intervention. But it's your choice.

For links, you have to configure it there: admin > settings > hostname.

RE: Changing localhost:3000 ??! - Added by Antti Perkiömäki over 9 years ago

Ah thanks, I did try to change that once and after that the Redmine didn't start correctly but now it seems to work fine... either I did something wrong at my first try or it was Monday ;)

(1-4/4)