redmine 1.4 can not use mongrel?

Added by Steven Wong over 7 years ago

enviroment :
windows
mysql 5.X
redmine 1.4

  • LOCAL GEMS ***

actionmailer (2.3.14)
actionpack (2.3.14)
activerecord (2.3.14)
activeresource (2.3.14)
activesupport (2.3.14)
bundler (1.1.3, 1.1.1)
cgi_multipart_eof_fix (2.5.0)
coderay (1.0.6, 1.0.5)
fastercsv (1.5.4)
gem_plugin (0.2.3)
i18n (0.6.0, 0.4.2)
json (1.6.5)
mongrel (1.1.5 x86-mingw32)
mysql (2.8.1 x86-mingw32)
net-ldap (0.3.1)
pg (0.13.2 x86-mingw32, 0.9.0 x86-mingw32)
rack (1.4.1, 1.1.3)
rails (2.3.14)
rake (0.9.2.2)
rdoc (3.12)
rmagick (2.13.1)
ruby-ole (1.2.11.3)
ruby-openid (2.1.8)
spreadsheet (0.6.8)
sqlite3 (1.3.5 x86-mingw32)
tzinfo (0.3.33)

when I use commmand line:

ruby script/server mongrel -e production
it appears an error.
########################
C:\Test_PRJ\redmine-1.4>ruby script/server mongrel -e production
C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/depend
encies.rb:182:in `require': no such file to load -- mongrel (MissingSourceFile)
        from C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_s
upport/dependencies.rb:182:in `require'
        from C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_s
upport/dependencies.rb:547:in `new_constants_in'
        from C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_s
upport/dependencies.rb:182:in `require'
        from C:/Ruby187/lib/ruby/gems/1.8/gems/rack-1.1.3/lib/rack/handler/mongr
el.rb:1
        from C:/Ruby187/lib/ruby/gems/1.8/gems/rack-1.1.3/lib/rack/handler.rb:17
:in `const_get'
        from C:/Ruby187/lib/ruby/gems/1.8/gems/rack-1.1.3/lib/rack/handler.rb:17
:in `get'
        from C:/Ruby187/lib/ruby/gems/1.8/gems/rack-1.1.3/lib/rack/handler.rb:17
:in `each'
        from C:/Ruby187/lib/ruby/gems/1.8/gems/rack-1.1.3/lib/rack/handler.rb:17
:in `get'
        from C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/commands/server.
rb:45
        from script/server:3:in `require'
        from script/server:3
###################################

Could redmine 1.4 support the mongrel?

Replies (6)

RE: redmine 1.4 can not use mongrel? - Added by Cassiano Monteiro over 7 years ago

I'm also getting problems with mongrel. I tried to use the patch on issue #7688, but still not working. Mongrel doesn't render the page, and I´m getting some huge stack trace, but without the exception... =/

RE: redmine 1.4 can not use mongrel? - Added by Jean-Philippe Lang over 7 years ago

Create a Gemfile.local at the root of your Redmine directory with the following content:

gem "mongrel"

Then `bundle install` and start Redmine.

RE: redmine 1.4 can not use mongrel? - Added by Cassiano Monteiro over 7 years ago

That worked. But it´s strange, since it didn´t change my current mongrel installation.

Thanks!

RE: redmine 1.4 can not use mongrel? - Added by Jean-Philippe Lang over 7 years ago

Redmine 1.4.0 now uses Bundler to manage gems dependencies. Any gem that is required to run your Redmine instance (eg. the mongrel gem if you're running it with mongrel) needs to be added to Gemfile.local, otherwise it won't be loaded.

redmine 1.4 can not use mongrel? - Added by vikram das about 7 years ago

it's very typical....

RE: redmine 1.4 can not use mongrel? - Added by Jan Niggemann (redmine.org team member) about 6 years ago

Un-sticking this, mongrel is unmaintained, there are better alternatives (that even work with ruby > 1.9.2)

(1-6/6)