An error occurred while sending mail (Expected [...]/version.rb to define VERSION)

Added by k c over 7 years ago

Email support (GMail) broke for me after upgrading from 1.3.x to 1.4.0. When I try to send a test email I get the following error:

An error occurred while sending mail (Expected /opt/local/apache2/htdocs/redmine/app/models/version.rb to define VERSION)

Some useful info:
# ruby --version
ruby 1.9.3p125 (2012-02-16 revision 34643) [x86_64-darwin10]

# gem list

*** LOCAL GEMS ***

actionmailer (2.3.14)
actionpack (2.3.14)
activerecord (2.3.14)
activeresource (2.3.14)
activesupport (2.3.14)
bigdecimal (1.1.0)
bundler (1.1.3)
coderay (1.0.6)
daemon_controller (1.0.0)
fastthread (1.0.7)
i18n (0.4.2)
io-console (0.3)
json (1.5.4)
minitest (2.5.1)
mysql2 (0.2.18)
net-ldap (0.3.1)
passenger (3.0.12)
pg (0.13.2)
rack (1.1.3)
rails (2.3.14)
rake (0.9.2.2)
rdoc (3.9.4)
rmagick (2.13.1)
ruby-openid (2.1.8)
sqlite3 (1.3.6)
tzinfo (0.3.33)

Any help on this issue would be appreciated.

Replies (3)

RE: An error occurred while sending mail (Expected [...]/version.rb to define VERSION) - Added by Tim A over 7 years ago

Exactly same issue here! Configuration.yml contains only this:

production:
  email_delivery:
    delivery_method: :smtp
    smtp_settings:
      tls: true
      enable_starttls_auto: true
      address: "smtp.gmail.com" 
      port: 587
      domain: "smtp.gmail.com" # 'your.domain.com' for GoogleApps
      authentication: :plain
      user_name: "projects@example.com" 
      password: "password" 

Environment:

ruby 1.9.3p125 (2012-02-16 revision 34643) [i686-linux]
*** LOCAL GEMS ***

actionmailer (2.3.14)
actionpack (2.3.14)
activerecord (2.3.14)
activeresource (2.3.14)
activesupport (2.3.14)
bundle (0.0.1)
bundler (1.1.3)
coderay (1.0.6)
daemon_controller (1.0.0)
diff-lcs (1.1.3)
edavis10-object_daddy (0.4.3)
fastthread (1.0.7)
gitolite (0.0.3.alpha)
grit (2.4.1)
hashery (1.4.0)
i18n (0.4.2)
json (1.6.6)
lockfile (2.1.0)
metaclass (0.0.1)
mime-types (1.18)
mocha (0.10.5)
mysql (2.8.1)
mysql2 (0.2.18)
net-ldap (0.3.1)
net-ssh (2.3.0)
passenger (3.0.12)
pg (0.13.2)
rack (1.1.3)
rails (2.3.14)
rake (0.9.2.2)
rdoc (3.12)
rmagick (2.13.1)
ruby-openid (2.1.8)
rubygems-bundler (0.9.0)
rvm (1.11.3.3)
shoulda (2.10.3)
sqlite3 (1.3.6)
tzinfo (0.3.33)

RE: An error occurred while sending mail (Expected [...]/version.rb to define VERSION) - Added by Tim A over 7 years ago

I found the solution:

1) I upgraded to redmine 1.4.1 (which isn't essential I think)
2) The main reason of the bug: uninstalled action_mailer_optional_tls plugin. Redmine 1.4.0 can connect gmail without this plugin, so there is a conflict between them both, so make sure you uninstalled this plug.

(1-3/3)