Install problem: Won't serve static files.

Added by Chris Pitzer over 9 years ago

I installed redmine on my DreamHost server using the guide here: http://alandaveline.com/blog/2008/05/12/redmine-on-dreamhost/

Everything seems to be working right - I can add users, projects, etc... but redmine isn't serving the static files necessary for the look of the app. No css/images/etc. So the site looks like it would if your turned styles off in Firefox.

Any suggestions for me? I'm guessing the problem is somewhere in my .htaccess file... maybe.

You can see my redmine install at redmine.lofiart.com - the symptom of my problem should be obvious even from the login page.

Feel free to reply here or find me via AIM at chrisptzr

Cheers!

Replies (3)

RE: Install problem: Won't serve static files. - Added by Chris Pitzer over 9 years ago

And here's this info...

[redbull]$ RAILS_ENV=production script/about
/usr/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies. rb:263:in `load_missing_constant': uninitialized constant Rails::Info (NameError )
from /usr/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/ dependencies.rb:453:in `const_missing'
from /usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/commands/about.rb:2
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_ original_require'
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `requ ire'
from script/about:3

RE: Install problem: Won't serve static files. - Added by Anup Narkhede over 9 years ago

I got the same problem today. However I solved it by doing this:
1) Pointed the subdomain to my installed /public directory
2) Deleted the .htaccess file which comes from redmine. I created a dummy project on the server through rails command, then copied the .htaccess file and replaced it in the redmine public dir.

It works now!

RE: Install problem: Won't serve static files. - Added by Chris Pitzer over 9 years ago

I managed to fix the issue by running 'ruby rortest' and replacing the .htaccess file in my redmine install with the newly created one in the rortest folder.

I posted the details here as a response to the install article: http://alandaveline.com/blog/2008/05/16/redmine-on-dreamhost-with-passenger/

(1-3/3)