Dwarf plugin problem

Added by Julio Helden over 7 years ago

Hi guys, I instlled the dwarf plugin in my Redmine enviroment. However, when I try to create an item into the backlog I receive the following problem and nothing happens:

http://localhost:3000/adtaskinl/create 400 (Bad Request)

I only have one tracker (feature) in my redmine wich is linked to my project. I deleted the other trackers (Bug and Support) once the Dwarf plugin was using the tracker Bug to create the item.

Cheers,
Julio Helden

Replies (3)

RE: Dwarf plugin problem - Added by Stefan H Singer over 7 years ago

In AgileDwarfs settings (administration->plugins), what tracker is set to be used as default for new tasks?

RE: Dwarf plugin problem - Added by Julio Helden over 7 years ago

Hi Stefan, you were right :). I followed your instructions and now I am able to create a new task in the backlog.
The problem now is that when I click the button to create a new task in the backlog, Dwarf puts a green box inside my backlog but inside it there is no information. Only appears a clean green box (without subject, estimate and owner fields). I inspected my log and no error was throwed (see log1 below), but no field is inside the green box. However, if I go out the sprint tab menu and come back again the fields magically appears inside the green task box. If i try to click on [subject] for example the field disappears again and I receive the following JS error "Uncaught TypeError: Cannot call method 'attr' of null". Do you have an idea about what is happening ?
You will find enclosed in this thread the print screen of my browser when I try to create a task using Dwarf plugin.

Cheers.

log1:

Started POST "/adtaskinl/create" for 127.0.0.1 at 2012-08-22 15:19:21 +1200
Processing by AdtaskinlController#create as */*
Parameters: {"subject"=>"[Subject]", "fixed_version_id"=>"", "project_id"=>"1", "authenticity_token"=>"KbFLvRCXzT581dHSMJCJ/L6FHdIIvG0heTzxgl45Ltc="}
Rendered mailer/_issue.text.erb (0.0ms)
Rendered mailer/issue_add.text.erb within layouts/mailer (1.0ms)
Rendered mailer/_issue.html.erb (0.0ms)
Rendered mailer/issue_add.html.erb within layouts/mailer (0.0ms)
Rendered text template (0.0ms)
Completed 200 OK in 116ms (Views: 1.0ms | ActiveRecord: 41.0ms)

RE: Dwarf plugin problem - Added by Stefan H Singer over 7 years ago

I just noticed I got the same issue here :) You should report it in their github repo!

(1-3/3)