Defect #11051

reposman.rb fails in 1.4.2 because of missing require for rubygems

Added by Martin Corino over 5 years ago. Updated over 5 years ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:-% Done:

0%

Category:SCM extra
Target version:2.0.2
Resolution:Fixed Affected version:1.4.2

Description

In older version(s) of Redmine (1.2 in our case) rubygems is implicitly loaded by one of the other support libraries required at the start of the script.
In 1.4.2 these libraries have changed and implicit loading of rubygems has gone leading to a LoadError on "require 'activeresource'".
Adding a "require 'rubygems'" before this code solves the issue.

Associated revisions

Revision 9742
Added by Jean-Philippe Lang over 5 years ago

Adds missing require 'rubygems' (#11051).

History

#1 Updated by Martin Corino over 5 years ago

We're running Redmine 1.4.2 using MRI 1.8.7 and Rails 2.3.14

#2 Updated by Toshi MARUYAMA over 5 years ago

  • Category changed from SCM to SCM extra

#3 Updated by Jean-Philippe Lang over 5 years ago

  • Status changed from New to Resolved
  • Target version set to 1.4.3
  • Resolution set to Fixed

I'm using ruby1.9.3 + rubygems 1.8.23 and it actually works as is.
The fix is committed in r9742 anyway, thanks.

#4 Updated by Martin Corino over 5 years ago

Jean-Philippe Lang wrote:

I'm using ruby1.9.3 + rubygems 1.8.23 and it actually works as is.

That's correct. MRI 1.9.2+ loads rubygems by default. The pre-1.9 versions do not.

#5 Updated by Jean-Philippe Lang over 5 years ago

  • Target version changed from 1.4.3 to 2.0.2

Merged in 1.4 and 2.0.

#6 Updated by Jean-Philippe Lang over 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF