Patch #1127

Issue closed not strikethru'ed (with patch)

Added by W Snyder over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:2008-04-28
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:UI
Target version:0.8

Description

I was thinking closed issues should be stikethru'ed, so I went to implement this and found the code already there!

The problem is simply the default application.css has issue.closed instead of issue-closed; patch below.

strike.patch Magnifier (755 Bytes) W Snyder, 2008-04-28 15:31

strike_closed_issue_link.diff Magnifier - strikethru closed issues (609 Bytes) Otávio Sampaio, 2008-07-10 15:20

closed_issues_strikethrough_in_css.patch Magnifier - apply css classes 'issue closed' to issue links (1.61 KB) Peter Van den Bosch, 2008-07-19 19:18

Associated revisions

Revision 1680
Added by Jean-Philippe Lang over 9 years ago

Strikethru closed issue links (#1127).

History

#1 Updated by Jean-Philippe Lang over 9 years ago

  • Status changed from New to Closed
Actually, there is no problem with this:
  • issue-closed css class is used for entries in the activity view. I don't want these entries to be stikethru'ed. A different icon shows that an issue was closed.
  • issue.closed (that applies to html elements that have both the issue and closed class) is used for links to a closed issue (eg. #1124).

#2 Updated by W Snyder over 9 years ago

  • Status changed from Closed to Reopened

Fair enough; I'll redo this patch then.

What I was looking for is on the "activity page" and bug lists that anywhere a closed bug number is listed it will look like this:

Bug# Foo bar baz

For example look at your own:
http://www.redmine.org/projects/activity/redmine

I think all of the issue numbers that are closed should be strikethru'ed. This makes it easier to scan for new issues. Likewise the # column in the issues report list.

The patch did the names but not the numbers; I would have rather had the numbers anyways but got mislead by the use of the class as you described.

Thanks for correcting my misunderstanding on how this all worked.

#3 Updated by Otávio Sampaio over 9 years ago

Hy all,

I'm a Redmine newbie but I do appreciate all the effort that has been made. Great tool. I have something to add to this ticket. I use a lot the calendar and the gantt chart. But sometimes is very annoying don't when we couldn't easily see the issues that are already closed. That's why I attached a patch the change the link_to_issue behave.

#4 Updated by Peter Van den Bosch over 9 years ago

Hi,

I've added a patch which does about the same as Otávio's patch above, but by applying the css classes 'issue closed' when using link_to_issue instead of adding <del> tags.
This affects the issue links in gantt, calendar, timelog and issue relations. Also, the patch removes the strikethrough in roadmap en versions rhtmls, since they would be provided by using link_to_issue.

#5 Updated by Jean-Philippe Lang over 9 years ago

  • Category set to UI
  • Status changed from Reopened to Closed
  • Target version set to 0.8

Patch from Peter applied in r1680.

Also available in: Atom PDF