Feature #12249

Configurable required fields per tracker/role with 'Not visible'

Added by claude g almost 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Custom fields
Target version:-
Resolution:Duplicate

Description

As discussed in Feature #703, could it be possible to add 'Not visible' in new 'fields permissions' form of workflows ?
This will have many impacts on :
  • issue form,
  • notifications. They will be different per role. That will happen also if only one of those hidden field is modified? Could we have no notification for people who don't have access to this custom field?
  • issues tables with filters without those custom fields?

A simplification could be to decide that if one field is hidden, it is always hidden for this role and it is not depending on issue status.

What could you suggest please ?


Related issues

Duplicates Redmine - Feature #12005: Mightful workflow field enhancement: hide New

History

#1 Updated by Daniel Felix almost 5 years ago

Seems to be a duplicate of: #12005

#2 Updated by claude g almost 5 years ago

You are right, this tracker can be cancelled.

#3 Updated by Jean-Philippe Lang almost 5 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Also available in: Atom PDF