Defect #12954

Required field can't be read-only

Added by Daniel Felix almost 5 years ago. Updated 10 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues workflow
Target version:-
Resolution:Duplicate Affected version:2.3.2

Description

Hi,

I've encountered some bug, which prevents the creation of a new issue.

Maybe this is solved by commiting #12005, but in the current trunk and Redmine 2.2.2 this bug is reproduceable.

Ways to reproduce this error:
  1. Set custom field as required
    custom field is set to required
  2. Define field as read-only in workflow
    workflow sets field to read-only
  3. Try to add issue, as you could see the field isn't displayed in the form but is checked in the required process
    configuration raises error

Maybe this one is related with #12856, which hasn't any relation to custom fields, but the result seems to be the same.

Some suggestion to solve this:
Commit patch from #12005, remove required checkbox from custom fields, set currently required fields to "required" in all workflows. This way there is no way to set a field as read-only and required.

Best regards,
Daniel

custom_field_required.png - custom field is set to required (18.7 KB) Daniel Felix, 2013-01-23 10:32

workflow_read_only.png - workflow sets field to read-only (27.9 KB) Daniel Felix, 2013-01-23 10:32

failure_in_issues.png - configuration raises error (40 KB) Daniel Felix, 2013-01-23 10:32


Related issues

Related to Redmine - Feature #12005: Mightful workflow field enhancement: hide New
Related to Redmine - Defect #12856: Required field Category cannot be edited by Non Member us... Needs feedback
Duplicates Redmine - Defect #19193: Custom Field definition inconsistency New

History

#1 Updated by Daniel Felix almost 5 years ago

  • Description updated (diff)

#2 Updated by Daniel Felix almost 5 years ago

  • Description updated (diff)

#3 Updated by Daniel Felix over 4 years ago

  • Affected version (unused) changed from 2.2.2 to 2.3.2
  • Affected version changed from 2.2.2 to 2.3.2

I can reproduce this, even with the current release or with 2.3.2-devel (r12012).

It would be good to prevent setting a field to "hidden", if it is a required field. Or on the other hand, the field should be only required if it is visible to the user.

#4 Updated by Go MAEDA 10 months ago

  • Duplicates Defect #19193: Custom Field definition inconsistency added

#5 Updated by Go MAEDA 10 months ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Fixed by #19193 (Redmine 3.1.0).

Also available in: Atom PDF