Defect #13000

Links to revisions not replaced after incorrect revision

Added by Arnis Juraga almost 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Text formatting
Target version:-
Resolution:Duplicate Affected version:2.2.2

Description

I am using version 2.2.0, but the problem is in redmine.org current version also).
I can reproduce it here:

This is real revision: r11281 (link works fine)

This is NOT REAL revision, just bulk data: commit:r1445535 (not linking, of course, as this is not real revision)

And now again: this is real revision: r11281 (and You see - revision is not replaced anymore and any further.)

r11281 r11281 r11281
source:some/file - does not work yet.

But If you specify project:
redmine:source:some/file - then it works,
And revisions works again! :)
r11281

sshot-1.png - Print screen, if this will be fixed in source (21.2 KB) Arnis Juraga, 2013-01-28 00:47


Related issues

Duplicates Redmine - Defect #12930: 404 Error when referencing different project source files... Closed

History

#1 Updated by Toshi MARUYAMA almost 5 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

rNNN is for revision number (Subversion and Mercurial revision number).
commit:abcdef is for hash id (Git revision hash and Mercurial revision number).

#2 Updated by Toshi MARUYAMA almost 5 years ago

  • Status changed from Closed to Reopened
  • Resolution deleted (Invalid)

#3 Updated by Toshi MARUYAMA almost 5 years ago

  • Status changed from Reopened to Needs feedback

#5 Updated by Toshi MARUYAMA almost 5 years ago

  • Status changed from Needs feedback to Confirmed

#6 Updated by Jean-Philippe Lang almost 5 years ago

  • Status changed from Confirmed to Closed
  • Resolution set to Duplicate

I'm closing it as duplicate of #12930. The fix solves this issue as well. Note that commit:r1445535 is not a valid tag, commit is interpreted as a project identifier. The correct syntax is r1445535 or commit:1445535 (without the r).

Also available in: Atom PDF