Feature #13792

Fixing via git push should not break workflow

Added by Ivan Kanis about 6 years ago. Updated over 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate

Description

We are running Redmine to 2.2.0.

Our typical workflow is New -> Assigned -> Fixed -> Verified -> Close

When we do push with git we run a hook to update bugs:

curl -sk "https://redmine.vo.com/sys/fetch_changesets?id=${id}&key=${key}"

Bugs that are referenced in the commit message are indeed Fixed.

However, we don't want this mechanism to break our workflow. I mean that an issue that is New or Verified should not become Fixed.

Am I making sense ?


Related issues

Duplicates Redmine - Defect #13762: SCM auto status change bypassses roles and permissions Confirmed
Copied from Redmine - Feature #12814: Ability to specify target version sort order Reopened

History

#1 Updated by Go MAEDA over 3 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing this issue as a duplicate of #13762.

#2 Updated by Go MAEDA over 3 years ago

  • Duplicates Defect #13762: SCM auto status change bypassses roles and permissions added

Also available in: Atom PDF