Defect #13990

Trac importer breaks on exotic filenames and ruby 1.9+

Added by Jean-Baptiste Barth over 4 years ago. Updated over 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Baptiste Barth% Done:

0%

Category:Importers
Target version:2.4.0
Resolution:Fixed Affected version:

Description

See: http://www.redmine.org/boards/2/topics/31188, also reported in other forum threads and here.

The problem is due to the fact that String#[] changed between ruby 1.8 and 1.9. In 1.8 x[0] would return a fixnum representing the character, while it returned the character itself in 1.9 (1.8 doc, 1.9 doc). It's easily explained by the unicode support improvements in 1.9 and the fact that a single 1.9 character can map to multiple codepoints.

The easiest workaround is to let the code as is for 1.8 but only take the first codepoint above (unicode strings can have multiple codepoints per character...).

Associated revisions

Revision 11796
Added by Jean-Baptiste Barth over 4 years ago

Fix Trac importer breaking on exotic characters with ruby 1.9+ (#13990).

History

#1 Updated by Jean-Baptiste Barth over 4 years ago

  • Status changed from Confirmed to Closed
  • Resolution set to Fixed

Also available in: Atom PDF