Defect #1436

Bad rendering on projects/add

Added by Pierre Paysant-Le Roux over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:2008-06-12
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:UI
Target version:0.7.2
Resolution:Fixed Affected version:

Description

  • Go to /projects/add (must be admin) (note that the page has no title)
  • Enter only in the form
  • Click save button

Error are reported and the page is scrambled. Observed on Firefox 2 and 3.

A workaround is to replace this line of app/views/layouts/base.rhtml
<h1><%= h(@project ? @project.name : Setting.app_title) %></h1>
by this one
<h1><%= h((@project and !@project.name.blank?) ? @project.name : Setting.app_title) %></h1>

Associated revisions

Revision 1526
Added by Jean-Philippe Lang over 9 years ago

Fixed: page has no title when adding a project (#1436).

History

#1 Updated by Pierre Paysant-Le Roux over 9 years ago

  • Enter only in the form
    is
  • Enter only a name in the form

#2 Updated by Jean-Philippe Lang over 9 years ago

I couldn't reproduce the problem. But the page has no title indeed, when adding a new project.
I've applied a different fix in r1526 (display the project name only after it was saved).
Can you confirm it's OK ?

#3 Updated by Pierre Paysant-Le Roux over 9 years ago

  • Status changed from New to Resolved

r1526 solved this issue.

#4 Updated by Jean-Philippe Lang over 9 years ago

  • Status changed from Resolved to Closed
  • Target version set to 0.7.2
  • Resolution set to Fixed

Thanks.

Also available in: Atom PDF