Feature #15535

"Magic links" to notes: display note number in link text

Added by Mehmet Soyturk almost 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate

Description

#2715 adds links to notes in a specific task. An example of such a link to the note closing the task: #2715-42.

I think that it would be better if the link text also contains the note number, like this: # 2715-42. It would be handy especially for the notes near the end of the page, because in that case the note won't be displayed at the top of the screen after following the link.

This will also help with discoverability / learnability of the "Magic links to notes" feature. Right now, when I need to make such a link, I have to search google to remember how to do that. Sometimes, I just don't even mind and paste the full URL as http://www.redmine.org/issues/2715#note-42.


Related issues

Duplicates Redmine - Feature #12912: Issue-notes Redmine links: append actual note reference t... Closed

History

#1 Updated by Mehmet Soyturk almost 4 years ago

Some context from our internal RedMine usage:

  • I see full URLs as http://www.redmine.org/issues/2715#note-42 are used
  • Some people just use plain words (because they don't know the feature exists?): the message 42 from #2715
  • Sometimes, plain words (or a full URL) are really needed, because otherwise people would not understand I have it about a specific message. For example, assume that people already know what #2715 is about. If I say " #2715-42 states that... " then people just won't understand that I'm having it about a specific message. I have to explicitly say "comment 42 from #2715-42 states that...".

#2 Updated by Mischa The Evil almost 4 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

This is a duplicate of #12912, which was fixed/implemented for 2.4.0.

#3 Updated by Mischa The Evil almost 4 years ago

  • Duplicates Feature #12912: Issue-notes Redmine links: append actual note reference to rendered links added

Also available in: Atom PDF