Defect #15705

new local .yml file not picked up by the user interface

Added by David Tremblay almost 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:I18n
Target version:-
Resolution:Invalid Affected version:2.4.1

Description

I created a new language file to deal with specifics of the subject matter in the projects we will managed

(followed http://www.redmine.org/projects/redmine/wiki/HowTo_translate_Redmine_in_your_own_language)

cp en.yml en-MJ.yml

edited some fields (issues --> tasks issue --> task)

change the first line of the field from

en:

to

en-MJ:

ran

rake locales

I see it updating and parsing the files

Updating file ./config/locales/en-MJ.yml
parsing ./config/locales/en-MJ.yml...

restart redmine by restarting apache

log in as admin, check in my account, no new language...

so I did a little experiment.

instead I took the en-GB.yml file made a backup of it and did the same edits right in the en-GB.yml file ..

(rake locales, restart redmine, login as admin)

Now if I choose en-GB.yml I can see the edit.

So the problem is about adding a new language, am I wrong ?

I've been searching for hours, if you have any idea on how I can make it work you are most welcome

History

#1 Updated by Toshi MARUYAMA almost 4 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

You need to change "general_lang_name" and clear cache.

Also available in: Atom PDF