Defect #1719

File Download automatically triggered while login.

Added by Anke Maklo over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:2008-07-31
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Attachments
Target version:0.8
Resolution:Fixed Affected version:0.7.3

Description

I met a strange bug and have pinned down it's cause.

This bug was confirmed using Opera 9.51 and Firefox several times.

I use redmine 0.7.3 and have uploaded some images as files to redmine. Then I linked the images as at the frontpage and in the project list. If the administrator denies anonymous and unregistred users the permission to watch files of public projects, then the image wont appear neither on the frontpage nor in the project list. That's alright.

But here comes the defect. If you login in your redmine account, the image files will be automatically sent to you as download! For some the files are send to you, instead of embedding the files in the frontpage. It does not happen 10 out of 10 times, but maybe 6 times out of 10. I notived this behaviour because for some reason my file download counter was sky rocket high after I denied the "View files" permission for unregistred and anonymous.

History

#1 Updated by Jean-Philippe Lang over 9 years ago

  • Status changed from New to Closed
  • Resolution set to Fixed

Before r1695, the url requested by an unauthorized user was stored in session so that the app could redirect him to this url after logging in. That's why your problem occurs.

This is no longer the case and your problem should be fixed by r1695.
Reopen if needed.

Also available in: Atom PDF