Defect #17559

Same file gets Attach at atime with 21 FileUpload fields and other 8 uploading status on waiting.

Added by Amit Baswa about 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Attachments
Target version:-
Resolution:Duplicate Affected version:2.4.2

Description

Hi there,

On our Redmine application when we try to attach the file, after choosing any file to attach the redmine application automatically starts uploading the file with 2 instants and other 8 on weaiting. Also, it creates 21 fileupload field. This is unexpected behavious, we had not made any changes on redmine code.
This problem start occured to be unknown.

I had attached the ScreenShot of issue. Kindly let us know the fix on it.
Keeping it HIGH, as this is creating an issue while uploading large files.

HEY, this is unexpected, I can see same issue on redmine.org website too....!!! ATTACHING SS

Regards,
Amit

error.png - Error on our site (74 KB) Amit Baswa, 2014-07-25 15:59

Untitled.png - Error on Redmine (127 KB) Amit Baswa, 2014-07-25 16:01

redmine_file_upload.patch Magnifier (970 Bytes) George Gensure, 2014-07-25 16:59


Related issues

Duplicates Redmine - Defect #17151: File upload broken on Chrome 36 Closed

History

#1 Updated by Amit Baswa about 3 years ago

Hi there,

Just now checked with other browser. The problem is only with CHROME browser. Other browsers are working fine with attachment funcationality.
Please check if we can do somwthing on this issue.

--Amit

#2 Updated by Zach Auclair about 3 years ago

I am seeing this issue as well; to add another error scenario, I selected 4 files to upload, but only the first 2 actually got uploaded.

#3 Updated by George Gensure about 3 years ago

I have attached a fix for this. The .clone() jquery call is causing a recursive loop through the addInputFiles(this) onchange event handler. This patch disables the onchange handler for the duration of the clone call, restoring it on the cloned element when complete.

Please integrate this into trunk at the earliest possible opportunity.

#4 Updated by Toshi MARUYAMA about 3 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate with #17151.

#5 Updated by Toshi MARUYAMA about 3 years ago

  • Duplicates Defect #17151: File upload broken on Chrome 36 added

Also available in: Atom PDF