Defect #17679

Attached inline image not working

Added by Kira Schmieja about 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:
Priority:LowDue date:
Assignee:-% Done:

0%

Category:Wiki
Target version:-
Resolution:Duplicate Affected version:2.5.2

Description

The documentation says the following on attaching inline images:

Inline images

   * !image_url! displays an image located at image_url (textile syntax)
   * !>image_url! right floating image
   * If you have an image attached to your wiki page, it can be displayed inline using its filename: !attached_image.png!

The third point does not appear to work. Trying to attach the image will only result in the text being shown

Example:

!Test Image.png!

Test Image.png (5.17 KB) Kira Schmieja, 2014-08-13 13:02


Related issues

Duplicates Redmine - Defect #10189: Inline image does not work with spaces in file name New

History

#1 Updated by Michael Esemplare about 3 years ago

One point to make is that you have to escape the image filename so it would look like !Test%20Image.png! for the textile parsing to work.

After preliminary investigation I can confirm this bug exists with images that contain spaces in the file name.

#2 Updated by Michael Esemplare about 3 years ago

Duplicate of #10189.

Escaping the spaces would be required for the textile parsing to work, however it breaks the method redmine uses to lookup the file name.

The defect #10189 describes two possible resolutions, fixing the textile parser to support spaces or fixing redmine to unescape the link.

#3 Updated by James H about 3 years ago

+1
Inline Image calls do not work when file name has spaces.
Even using Percent encoding does not seem to work for me...

#4 Updated by Toshi MARUYAMA about 3 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Michael Esemplare wrote:

Duplicate of #10189.

Thank you for your pointing.

#5 Updated by Toshi MARUYAMA about 3 years ago

  • Duplicates Defect #10189: Inline image does not work with spaces in file name added

Also available in: Atom PDF