Defect #19368

Creating an issue without tracker_id attribute ignores custom field values

Added by Alex Last over 3 years ago. Updated over 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:REST API
Target version:3.0.1
Resolution:Fixed Affected version:3.0.0

Description

this is a regression in 3.0.0 from 2.6.x:

when creating new issues via REST API (specifically, I am using Redmine Java API library), I see
the standard JSon payload I used with Redmine 2.6.x is not accepted anymore:

{"issue": {"subject":"test for custom multi fields - set multiple values",
"project_id":369,
"start_date":null,
"custom_field_values":{"3":["V1","V3"]}
}
}

the server ignores values V1, V3 and assigns default V2 value to that multi-line custom field.

see test setMultiValuesForMultiLineCustomField() in
https://github.com/taskadapter/redmine-java-api/blob/master/src/test/java/com/taskadapter/redmineapi/IssueManagerTest.java

Associated revisions

Revision 14083
Added by Jean-Philippe Lang over 3 years ago

Fixed that creating an issue without tracker_id attribute ignores custom field values (#19368).

Revision 14084
Added by Jean-Philippe Lang over 3 years ago

Adds a test for setting multivalued custom fields with JSON (#19368).

Revision 14086
Added by Jean-Philippe Lang over 3 years ago

Fixed assertion (#19368).

Revision 14087
Added by Jean-Philippe Lang over 3 years ago

Fixed assertion (#19368).

Revision 14100
Added by Toshi MARUYAMA over 3 years ago

Merged r14084, r14086 and r14087 from trunk to 3.0-stable (#19368)

History

#1 Updated by Jean-Philippe Lang over 3 years ago

  • Subject changed from multi-line custom fields values are not accepted by Redmine 3.0.0 for new issues to Creating an issue without tracker_id attribute ignores custom field values
  • Status changed from New to Resolved
  • Assignee set to Jean-Philippe Lang
  • Target version set to 3.0.1
  • Resolution set to Fixed

The problem is not about your JSON nor the multivalued custom field. This is due to the fact that you don't provide a tracker_id attribute. This is fixed in r14083.

#2 Updated by Jean-Philippe Lang over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF