Defect #19374

MinGW thin and puma: Internal server error occoures when attachment file name contains non ASCII

Added by Shine Lee almost 3 years ago. Updated about 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Wont fix Affected version:

Description

I download redmine from https://bitnami.com/redirect/to/50832/bitnami-redmine-3.0.0-0-windows-installer.exe .
The bug is descriped in the attachments.

mysql: 5.5.42
redmine: 3.0
ruby: 2.0.0p594 (2014-10-27) [i386-mingw32]
windows server 2008

first.png (52.1 KB) Shine Lee, 2015-03-13 11:11

second.png (8.16 KB) Shine Lee, 2015-03-13 11:12

chinese.png (64.6 KB) Toshi MARUYAMA, 2015-03-13 12:02

中文.png (52.1 KB) Shine Lee, 2015-03-13 16:02

服务器声卡驱动更新及服务器的配置文档.doc (219 KB) david chung, 2015-07-17 06:03


Related issues

Related to Redmine - Defect #19321: MinGW thin and puma: non ASCII wiki page causes "Internal... Closed
Duplicated by Redmine - Defect #19398: Failed to get attachment with Chinese filename. Closed
Duplicated by Redmine - Defect #19450: Unable to download files named by Chinese words Closed
Duplicated by Redmine - Defect #19467: Downloading attachments will be wrong if the file names c... Closed
Duplicated by Redmine - Defect #19610: Attached files with cyrillic "И" in the name Closed
Duplicated by Redmine - Defect #19600: can't open attcment files that have hebrow file names Closed
Duplicated by Redmine - Defect #20024: 3.0.3版本,有些中文附件能下载,有些中文附件报Internal server error Closed
Duplicated by Redmine - Defect #19963: if attachment's name includes Chinese,it can't be download. Closed

History

#1 Updated by Toshi MARUYAMA almost 3 years ago

  • File chinese.png added
  • Status changed from New to Closed
  • Resolution set to Cant reproduce

I cannot reproduce.
Please contact bitnami team.

$ RAILS_ENV=production bin/about 

Environment:
  Redmine version                3.0.0.stable
  Ruby version                   1.9.3-p551 (2014-11-13) [x86_64-linux]
  Rails version                  4.2.0
  Environment                    production
  Database adapter               Mysql2
SCM:
  Subversion                     1.6.11
  Darcs                          2.2.0
  Mercurial                      2.8.2
  Cvs                            1.12.13
  Bazaar                         2.1.1
  Git                            1.7.1
  Filesystem                     
Redmine plugins:
  no plugin installed

$ LANG=C hg parent
changeset:   11858:4aeb24fe2746
branch:      3.0-stable
user:        jplang
date:        Sun Mar 08 10:37:37 2015 +0000
summary:     Merged r14065 (#19172).

#2 Updated by Toshi MARUYAMA almost 3 years ago

I cannot reproduce on ruby 2.0.0p598 (2014-11-13 revision 48408) [x86_64-linux], too.

#3 Updated by Toshi MARUYAMA almost 3 years ago

I cannot reproduce on my Windows 8.1 Pro, too.

$ RAILS_ENV=production ruby bin/about
DL is deprecated, please use Fiddle

Environment:
  Redmine version                3.0.0.stable
  Ruby version                   2.0.0-p598 (2014-11-13) [x64-mingw32]
  Rails version                  4.2.0
  Environment                    production
  Database adapter               Mysql2
SCM:
  Subversion                     1.8.9
  Mercurial                      1.8.1
  Git                            1.9.2
  Filesystem
Redmine plugins:
  no plugin installed

#4 Updated by Shine Lee almost 3 years ago

  • Status changed from Closed to Reopened

To reproduce this bug please upload png file,not txt file.

#5 Updated by Shine Lee almost 3 years ago

#6 Updated by Toshi MARUYAMA almost 3 years ago

I cannot reproduce.
Please contact bitnami team.

#7 Updated by Toshi MARUYAMA almost 3 years ago

  • Status changed from Reopened to Closed

#8 Updated by Toshi MARUYAMA almost 3 years ago

  • Duplicated by Defect #19398: Failed to get attachment with Chinese filename. added

#9 Updated by Toshi MARUYAMA over 2 years ago

  • Duplicated by Defect #19450: Unable to download files named by Chinese words added

#10 Updated by Toshi MARUYAMA over 2 years ago

  • Duplicated by Defect #19467: Downloading attachments will be wrong if the file names contain more than two chinese characters added

#11 Updated by micro bead over 2 years ago

two chinese characters can work,but more than two ones will be wrong.

#12 Updated by Toshi MARUYAMA over 2 years ago

  • Related to Defect #19321: MinGW thin and puma: non ASCII wiki page causes "Internal server error" added

#14 Updated by Toshi MARUYAMA over 2 years ago

  • Priority changed from High to Normal
  • Resolution changed from Cant reproduce to Invalid

#15 Updated by Toshi MARUYAMA over 2 years ago

  • Subject changed from Internal server error occoures when attachment file name contains Chinese Charactor to MinGW thin and puma: Internal server error occoures when attachment file name contains non ASCII

#16 Updated by Toshi MARUYAMA over 2 years ago

  • Duplicated by Defect #19610: Attached files with cyrillic "И" in the name added

#17 Updated by Toshi MARUYAMA over 2 years ago

  • Related to Defect #19600: can't open attcment files that have hebrow file names added

#18 Updated by Toshi MARUYAMA over 2 years ago

  • Related to deleted (Defect #19600: can't open attcment files that have hebrow file names)

#19 Updated by Toshi MARUYAMA over 2 years ago

  • Duplicated by Defect #19600: can't open attcment files that have hebrow file names added

#20 Updated by Toshi MARUYAMA over 2 years ago

  • Duplicated by Defect #20024: 3.0.3版本,有些中文附件能下载,有些中文附件报Internal server error added

#21 Updated by Toshi MARUYAMA over 2 years ago

  • Duplicated by Defect #19963: if attachment's name includes Chinese,it can't be download. added

#22 Updated by Toshi MARUYAMA over 2 years ago

Rails 4.2.3 fixed.

$ git tag --contains 4df216cb12e35
v4.2.3
v4.2.3.rc1

#23 Updated by david chung over 2 years ago

I download bitnami-redmine-3.0.4-1-windows-installer.exe,Rails version is V4.2.3,but this bug is not fixed yet.Can anybody help me?
reproduce steps:
1.upload a attachment,files name is "服务器声卡驱动更新及服务器的配置文档.doc"
2.you can found it can't be download.

PS:On bitnami redmine 3.0.x for linux version,it cannot be reproduce.

#24 Updated by Toshi MARUYAMA over 2 years ago

FTR: #19963#note-5.
Please contact bitnami team.

#25 Updated by Toshi MARUYAMA about 2 years ago

  • Resolution changed from Invalid to Wont fix

Also available in: Atom PDF