Defect #19538

Keywords in commit messages: journal entries are created even if nothing was changed

Added by Lukas Pirl over 3 years ago. Updated over 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:SCM
Target version:2.6.4
Resolution:Fixed Affected version:2.6.0

Description

Regarding Referencing issues in commit messages:

Assume I have configured the keyword "feedback" to set an issue status to feedback.
Further, issue #42 is already set to feedback.
Now I commit with a message "feedback #42".

Actual result: The issue is updated with the journal entry "Applied in changeset …".

Desired result: Since in fact nothing changes/was applied, the issue should not get an additional journal entry.

Associated revisions

Revision 14164
Added by Jean-Philippe Lang over 3 years ago

Keywords in commit messages: journal entries are created even if nothing was changed (#19538).

History

#1 Updated by Jean-Philippe Lang over 3 years ago

  • Subject changed from keywords in commit messages: journal entries are created even if nothing was changed to Keywords in commit messages: journal entries are created even if nothing was changed
  • Category changed from Issues to SCM
  • Status changed from New to Resolved
  • Assignee set to Jean-Philippe Lang
  • Target version set to 2.6.4
  • Resolution set to Fixed

Fixed in r14164.

#2 Updated by Jean-Philippe Lang over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF