Defect #20628

Standard field (Due Date) for Redmine not showing as required.

Added by Rafael Neves about 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues workflow
Target version:-
Resolution:Duplicate Affected version:2.6.2

Description

I´m using Redmine 2.6.2. Logged as admin user, standard field (Due Date) not required when adding a new issue, despite having set up as required on workflow field permission.

I mean, When logged as other user (not admin) it works fine (appears an red asterisk besides Due Date field), but i need to prevent ALL users to not forget to fill due date, even they are admin users. Is that a bug ? Possible to fix it ?

Thanks!

workflow_field_permission.JPG (15.8 KB) Rafael Neves, 2015-08-27 19:35

example_due_date_not_required.JPG (38.9 KB) Rafael Neves, 2015-08-27 22:21


Related issues

Duplicates Redmine - Defect #11887: Issue permission doesn't apply to Administrators New

History

#1 Updated by Rafael Neves about 2 years ago

Standard field (Due Date) for Redmine does not appears as required field.
see attached an example when i try to create a new issue as an admin user ( due date dos not appear with a red asterisk, like priority field for example).

#2 Updated by Toshi MARUYAMA about 2 years ago

  • Category changed from Issues permissions to Issues workflow
  • Status changed from New to Needs feedback

Rafael Neves wrote:

I´m using Redmine 2.6.2. Logged as admin user, standard field (Due Date) not required when adding a new issue, despite having set up as required on workflow field permission.

I cannot reproduce on 2.6.6.

#3 Updated by Toshi MARUYAMA about 2 years ago

Rafael Neves wrote:

Standard field (Due Date) for Redmine does not appears as required field.

I cannot reproduce on 2.6.6.

#4 Updated by Mischa The Evil about 2 years ago

I am not entirely sure, but this looks like an issue the same as reported in #11887.

#5 Updated by Rafael Neves about 2 years ago

thanks all. It was reported in Defect #11887 as Mischa said. Sorry for duplicating it.

#6 Updated by Rafael Neves about 2 years ago

To clarify, the rule explanned by Perico Os Palotes on
#11887#note-7
solved my issue

thanks!!

#7 Updated by Toshi MARUYAMA about 2 years ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Duplicate

Thank you for your feedback.

#8 Updated by Toshi MARUYAMA about 2 years ago

  • Duplicates Defect #11887: Issue permission doesn't apply to Administrators added

Also available in: Atom PDF