Defect #21227

Email reminders sent for closed issues

Added by Simeon Felis about 2 years ago. Updated over 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Email notifications
Target version:-
Resolution:Invalid Affected version:3.1.1

Description

We receive E-Mail reminders for closed tickets, too. I actually don't know how the emails are triggered. I did not add a cronjob for that. The only cronjob that runs is:

*/5 * * * * wget -O - "http://127.0.0.1/helpdesk_mailer/get_mail?key=secret" 

The ticket was closed on 10.11.2015.
The due date is 10.11.2015.
The email notification is sent every day (today is 13.11.2015)

My colleague receives mails with this parameters:

The ticket was closed on 04.11.2015
The due date is 04.11.2015
The email notification is sent every day (today is 13.11.2015)

We migrated on 04.11.2015 redmine from 2.3.3.stable to 3.1.1.stable
Issues that were closed before migration do not send notifications. According to /issue_statuses the status "Closed" is marked as "Issue closed".

Redmine info:

Environment:
  Redmine version                3.1.1.stable
  Ruby version                   2.1.5-p273 (2014-11-13) [x86_64-linux-gnu]
  Rails version                  4.2.4
  Environment                    production
  Database adapter               Mysql2
SCM:
  Subversion                     1.8.10
  Git                            2.1.4
  Filesystem                     
Redmine plugins:
  redmine_contacts               4.0.3
  redmine_contacts_helpdesk      3.0.1

installed_plugins.png (55.1 KB) Simeon Felis, 2016-03-23 11:58


Related issues

Related to Redmine - Defect #22670: Email reminder sent even if ticket is closed Needs feedback

History

#1 Updated by Simeon Felis about 2 years ago

I posted the same problem here:

#8108#note-11

I'm not sure if the old issue would be re-opened.

#2 Updated by Toshi MARUYAMA almost 2 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

https://github.com/rubynovich/redmine_contacts_helpdesk/blob/4aadaf80956/config/routes.rb#L15

match "helpdesk_mailer/get_mail" => "helpdesk_mailer#get_mail" 

#3 Updated by Simeon Felis over 1 year ago

  • Status changed from Closed to Reopened

I don't understand you advice. Shall I add, modify or delete this line (line 15)?
Are you sure this problem is related to the contacts plugin?

Our full plugins/redmine_contacts_helpdesk/config/routes.rb looks like this:

#custom routes for this plugin
resources :helpdesk_tickets, :only => [:edit, :destroy, :update]

resources :projects do
  resources :canned_responses, :only => [:new, :create]
end

resources :canned_responses do
  collection do
    post :add 
  end
end

match "helpdesk_mailer" => "helpdesk_mailer#index",:via => [:get, :post]
match "helpdesk_mailer/get_mail" => "helpdesk_mailer#get_mail", :via => [:get, :post, :put]
match "helpdesk/save_settings" => "helpdesk#save_settings", :via => [:get, :post, :put ]
match "helpdesk/get_mail" => "helpdesk#get_mail", :via => [:get, :post, :put]
match "helpdesk/delete_spam" => "helpdesk#delete_spam", :via => [:delete]
match "helpdesk/email_note.:format" => "helpdesk#email_note", :via => [:get, :post]
match "helpdesk/create_ticket.:format" => "helpdesk#create_ticket", :via => [:get, :post]
match "helpdesk/show_original" => "helpdesk#show_original", :via => [:get, :post]
match "helpdesk_reports/index/(:project_id)" => 'helpdesk_reports#index', :via => [:get, :post]
match "helpdesk_reports/staff_report/(:project_id)" => 'helpdesk_reports#staff_report', :via => [:get, :post]
match "helpdesk_reports/tickets_report/(:project_id)" => 'helpdesk_reports#tickets_report', :via => [:get, :post]

get "mail_fetcher/receive_imap" => "mail_fetcher#receive_imap" 
get "mail_fetcher/receive_pop3" => "mail_fetcher#receive_pop3" 

match 'tickets/:id/:hash' => 'public_tickets#show', :as => :public_ticket, :via => [:get, :post]
match 'tickets/:id/add_comment/:hash' => 'public_tickets#add_comment', :as => :public_ticket_add_comment, :via => [:get, :post]

match 'vote/:id/:hash' => 'helpdesk_votes#show', :via => :get, :as => 'helpdesk_votes_show'
match 'vote/:id/:hash' => 'helpdesk_votes#vote', :via => :post, :as => 'helpdesk_votes_vote'
match 'vote/:id/:vote/:hash' => 'helpdesk_votes#fast_vote', :via => :get, :as => 'helpdesk_votes_fast_vote'

get 'attachments/:id/:ticket_id/:hash/:filename', :to => 'attachments#show', :id => /\d+/, :filename => /.*/, :as => 'hashed_named_attachment'
get 'attachments/download_hashed/:id/:ticket_id/:hash/:filename', :to => 'attachments#download', :id => /\d+/, :filename => /.*/, :as => 'hashed_download_named_attachment'

#4 Updated by Toshi MARUYAMA over 1 year ago

  • Status changed from Reopened to Closed

Please contact plugin author.

#5 Updated by Toshi MARUYAMA over 1 year ago

Simeon Felis wrote:

Are you sure this problem is related to the contacts plugin?

"http://127.0.0.1/helpdesk_mailer/get_mail?key=secret"

#6 Updated by Markus Harrieder over 1 year ago

We contacted the plugin authot, but as expected, the issue is not related to the contacts plugin.

I'm sorry but it seems the problem is not in our plugin. This cronjob only receives e-mails and doesn't send any notifications

Even the line you higlighted says get_mail (helpdesk_mailer# get_mail ), our problem is sending notifications from Redmine.
The notification function is a default Redmine function and it is sending notifications for tickets which are already closed. This is a defect. If its not, please explain the behavior in more detail.

Thank you in advance!

Best regards,
Markus Harrieder

#7 Updated by Toshi MARUYAMA over 1 year ago

Please contact other plugin author.

#8 Updated by Simeon Felis over 1 year ago

We only have two plugins enabled:

As the author of the plugins stated, this seems not to be related to these plugins. Are there other plugins not visible here? Could you point me to the correct auther of these?

I have to clarify that this issue is listed in the daily reminder "...x issues are due in the next x days..." (I don't know the exact english version).

The issue that should not be listed there looks like this:

id tracker_id project_id subject description due_date category_id status_id assigned_to_id priority_id fixed_version_id author_id lock_version created_on updated_on start_date done_ratio estimated_hours parent_id root_id lft rgt is_private closed_on
6226 2 15 Postfach für Helpdesk Test Ein postfach dafür einrichten 2015-11-11 80 5 14 4 5 9 2015-10-30 14:57:01 2015-11-27 09:34:35 2015-10-30 100 6226 7 8 0 2015-11-27 09:34:35

status_id looks like this:

id name is_closed position default_done_ratio
1 New 0 1
2 In Progress 0 3
3 Resolved 0 4
4 Feedback 0 5
5 Closed 1 6
6 Rejected 1 7
7 Confirmed 0 2

#9 Updated by Simeon Felis over 1 year ago

  • Status changed from Closed to Reopened

#10 Updated by Toshi MARUYAMA over 1 year ago

  • Status changed from Reopened to Closed

We don't provide any technical support.

#11 Updated by Toshi MARUYAMA over 1 year ago

  • Related to Defect #22670: Email reminder sent even if ticket is closed added

Also available in: Atom PDF