Defect #21457

Issue percentage done not updating correctly when calculated from subtasks

Added by Stephane Evr almost 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate Affected version:3.1.0

Description

Here are some of my issue statuses:

Activity TBC is the status per default, and no % done is associated.

These are my parameters in issue tracking:

- Issue done ratio is associated to the issue status
- % done is calculated from subtasks.

Now I create an issue "t1", with "Activity TBC" status (no % done associated):

Then I create a subtask s1 with status "In progress 40%".

My t1 task looks like this (all fine):

Then, I manually change the status of t1 to "Started 20 %". Everything is still OK, % done of the parent task takes precedence over subtasks:

But Now, I want to change the status of t1 back to "Activity TBC", with no % associated:

Expected: % done of t1 should be calculated from its subtasks (here 40%) since no % is longer associated with it

I have encountered this problem with redmine versions 3.x (also with redmine 3.2.0)

My production configuration:

issue_statuses.PNG (13.1 KB) Stephane Evr, 2015-12-08 10:58

issue_tracking.PNG (29 KB) Stephane Evr, 2015-12-08 11:00

t1.PNG (16.2 KB) Stephane Evr, 2015-12-08 11:03

t1_2.PNG (20.6 KB) Stephane Evr, 2015-12-08 11:05

t1_3.PNG (21.3 KB) Stephane Evr, 2015-12-08 11:07

t1_4.PNG (21.7 KB) Stephane Evr, 2015-12-08 11:09

config.PNG (41.9 KB) Stephane Evr, 2015-12-08 11:12


Related issues

Duplicates Redmine - Defect #13116: When setting Redmine to update the done % by status paren... Closed

History

#1 Updated by Toshi MARUYAMA almost 2 years ago

  • Category set to Issues

#2 Updated by Toshi MARUYAMA almost 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #13116.

#3 Updated by Toshi MARUYAMA almost 2 years ago

  • Duplicates Defect #13116: When setting Redmine to update the done % by status parent tasks should have the status update according to the done % of the child tasks and not the status. This is the default behavior when you just update by issue. added

Also available in: Atom PDF