Feature #21863

Filter on open blockers only

Added by Rob Kinyon almost 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues filter
Target version:-
Resolution:Duplicate

Description

When I create a filter with "Blocked By", I get 6 options:
  • "is" <issue number>
  • "any issues in project" <project name>
  • "any issues not in project" <project name>
  • "no issues in project" <project name>
  • "any"
  • "none"

The problem is that the blocking issues aren't evaluated for being opened or closed. This means that my query will show issues that are "blocked by" issues that are all closed. Which isn't helpful.

In my mind, the query should either only consider issues as blockers if they are open or allow me to specify "any open" vs "any". This way, I can see which issues are ready for development by excluding issues which have an open blocker.

Environment:
  Redmine version                2.6.1.stable
  Ruby version                   2.1.5-p273 (2014-11-13) [x86_64-linux]
  Rails version                  3.2.21
  Environment                    production
  Database adapter               Mysql2

Related issues

Duplicates Redmine - Feature #16621: Ability to filter issues blocked by any/no open issues Closed

History

#1 Updated by Rob Kinyon almost 2 years ago

I have also just confirmed this behavior on http://demo.redmine.org/. I created two issues, made one block the other, closed the blocker, and still saw the blocked issue when searching on blockers.

#2 Updated by Rob Kinyon almost 2 years ago

I see some related issues:
  • #16621#note-8
    • This appears to fix the problem, but the demo site (is it on 3.2.0?) doesn't show this behavior.
  • #15029
  • #4985#note-7
  • #3625 (This issue may be a refinement of that one)

#3 Updated by Toshi MARUYAMA almost 2 years ago

  • Category changed from Issues to Issues filter
  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #16621.

#4 Updated by Toshi MARUYAMA almost 2 years ago

  • Duplicates Feature #16621: Ability to filter issues blocked by any/no open issues added

Also available in: Atom PDF