Defect #2200

error if registe a new user with too short password

Added by Anh Kỳ Huỳnh almost 9 years ago. Updated almost 9 years ago.

Status:ClosedStart date:2008-11-16
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Accounts / authentication
Target version:-
Resolution: Affected version:

Description

If I register a new user with very short password, I will get the error:

ActionView::TemplateError (Translation value "is too short (minimum is %d characters)" 
with arguments [] caused error 'too few arguments') on line #4 of account/register.rhtml:
1: <h2><%=l(:label_register)%></h2>
2: 
3: <% form_tag({:action => 'register'}, :class => "tabular") do %>
4: <%= error_messages_for 'user' %>
5: 
6: <div class="box">
7: <!--[form:user]-->

my ./script/about. I am using svn version of Redmine

Ruby version              1.8.7 (x86_64-linux)
RubyGems version          1.2.0
Rails version             2.1.1
Active Record version     2.1.1
Action Pack version       2.1.1
Active Resource version   2.1.1
Action Mailer version     2.1.1
Active Support version    2.1.1
Edge Rails revision       unknown
Application root          /home/sites/redmine
Environment               development
Database adapter          mysql
Database schema version   20081107110312

History

#1 Updated by Jean-Philippe Lang almost 9 years ago

I can't reproduce with Rails 2.1.0 and ruby 1.8.6.
I'll try do some tests with your conf, which is not the recommended one :/

#2 Updated by Jean-Philippe Lang almost 9 years ago

  • Status changed from New to Closed

Tested OK with latest trunk using ruby 1.8.7 and rails 2.1.2

Also available in: Atom PDF